Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1
Hi guys, I've started noticing something strange when riding. If I am riding at a steady speed where I am barely on the throttle once up to a cruising speed my bike seems to have a stutter to it. Once I roll onto the throttle it responds fine and no stutter. It's fine while accelerating too. It only happens when barely on the throttle regardless of the actual mph. I recently put a set of apes on and soldered the green connector for the throttle. It did not do it right after the bars, began a few weeks later. I tried cruising with the cruise control set and the stutter still happens once on a flat stretch with not much load on it. Does the fact the stutter still happen in cruise control, does that rule out the throttle in the bars? I've been told maybe a dirty throttle body, bad spark plugs, bad fuel filter.... I'll throw some new plugs in it tomorrow and see what happens and go from there. Anyone have any ideas or have experienced this?? My bike has 34k on it.
 

·
GONE BUT NOT FORGOTTEN
Joined
·
1,775 Posts
Check the connections on your O2 sensors. Maybe change the fuel filter.
 

·
Registered
Joined
·
7,263 Posts
Replace your plugs and if you're able to change the fuel filter. These are often overlooked when servicing the bike.
 

·
Registered
Joined
·
1,110 Posts
It never hurts to change the fuel filter but normally that will effect the heavier throttle loads more due to fuel demand. If you have no issues with acceleration but a slight stutter (usually a sign of lean a/f ratio) only at light throttle, I would check for an intake leak assuming you haven"t changed anything else like exhaust or intake.
 

·
Registered
Joined
·
204 Posts
Check your fuel pressures. I had a dyna that had a similar problem but it would backfire when I rolled into the throttle. Found a fuel line in the tank leaking causing my lean problem. Sometimes you can open the tank with it running and hear it if it has a leak Also look at the tps. Read it out with ohms while rolling the throttle if it goes o/l it has a bad spot
 
1 - 7 of 7 Posts
Top