Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hi everyone , long time lurker never had much to post about .

Today my 08 RG started showing the check engine light . Came here read about checking codes . Have codes ,,

PO120
PO123
PO131
PO151
P1510
P2135
And I discovered by accident that if I hold the brakes (front or back) enough to light up the tail light bike only revs very slowly . Release brakes and rev again seems to rev like full power . Rode around the block and seems to run OK. A quick look with a flashlight showed no obvious pinched wires . Plus I pulled the main fuse and it made no difference .

Have a big ride I wanted to go on tomorrow .
Think it might still be OK to go ?
 

·
Registered
Joined
·
6,614 Posts
The problem may not be in the handlebar area. Try putting some dielectric grease on the TCA plug. The TCA ( Throttle Control Actuator) is located to the rear of the air cleaner, disconnect the plug and put the dielectric grease on the plug where the pins will go in, clear the codes and ride the bike to see if the codes return.
 

·
Registered
Joined
·
6,614 Posts
The codes should clear make sure to PRESS and HOLD the odometer reset switch until "clear" is displayed. If you did this and you turned the ignition off and then turned the ignition on and started the bike and the codes returned then there is a problem that need to be addressed. Did you do the dielectric grease on the TCA plug?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I did clear the codes . They came up again . Have not checked that plug yet . May get to it tomorrow . Bike ran fine yesterday . Only goes into limp mode when holding brake on
Thanks for the ideas of what to check . Will talk to dealer by the end of the week .
 

·
Registered
Joined
·
6,614 Posts
A problem with the brake light switches will disable the cruise. Have you done any work to the bike that required the handlebar switch housings to be removed? In your original post you mentioned that you looked for pinched wires, a pinched wire most of the time is not real obvious so you may want to do a thorough inspection.
 

·
Registered
Joined
·
553 Posts
Check all the grounds especially any for the brake light, taillight and the battery and main frame grounds
If their is a bad ground when you put voltage to the brake light ( application of brakes) it could be searching for ground and causing erratic behavior in the electrical system, alot if electrical gremlins are caused by a bad ground

Sent from my DROID RAZR using Motorcycle.com Free App
 
1 - 7 of 7 Posts
Top