Road Glide banner

1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
OK....anyone else noticed ?....one of the first things I noticed when I got my 16 RG the end of Aug was the fit of the windshield at the base. I'd say about 3/16" space between the bottom of the ws and where it looks like it should lay in the rubber trim. The sides look like they're fitting correctly. Not sure why there'd be a gap....looks like it lays flat against the back part of the fairing but I have had bugs come up thru there with a little splatter on the inside bottom of the ws.....what say ye ? I looked at the trim kits mentioned in another post and they look like they're for earlier models...slightly different
this is pix w Klock ws but it fits the same.....not enuff miles yet to see any difference at the base.....Like the Klock so far otherwise
 

Attachments

·
Registered
Joined
·
4,404 Posts
Looks like the back fasteners are loose and the shiel got pushed back from the wind, or the aftermarket shield maker is off on his template.

My 16 inch LRS would look like that after a ride, but I could pull it forward back into place. Tightening the fasteners a little more took care of the movement.

Harley dies make a 3 piece trim for the Rushmore bikes.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
This pix was after installation...before I rode it at all.....I could tip it forward to make the front fit but then the back sides weren't under the trim pieces to suit me. The ws that was on it when it was new fit exactly the same....think I may put the original back on again for a bit.....maybe complain to the dealer and see what they say....my dealer is a couple hours away and I was way into the riding last season so I overlooked it. Just checking to see if anyone else had similar fit...
 
1 - 3 of 3 Posts
Top