Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter #1
Everything works, fuel pump lights. Hit start button and does nothing. Security lights don't stop blinking. Is there a reset? Dealer suggested key fob battery dead, I replaced still nothing. Any suggestions ? Than you.
 

·
Registered
Joined
·
6,625 Posts
Since the fuel pump works did you check for spark? If there is no spark then you need to chase down the problem.
If have spark and you have a tuner on the bike try unhooking it and see if the bike starts then.
 

·
Registered
Joined
·
809 Posts
Everything works, fuel pump lights. Hit start button and does nothing. Security lights don't stop blinking. Is there a reset? Dealer suggested key fob battery dead, I replaced still nothing. Any suggestions ? Than you.
If your fuel pump is pressurizing then it isn't the fob or security related. The first thing to check would be the battery, you need to load test it then I would look at the fuses, I would pull them and check for continuity with a multimeter. I have seen them where they looked good but when tested they where blown. If all the fuses are good then I would replace the starter relay, take it to an autoparts store and they should be able to match one up. After the relay then have a look at your starter button.
 

·
Registered
Joined
·
6,625 Posts
I must of missed he part where it wasn't cranking over.
There is the small wire going to the back of the starter which comes from the starter relay if that wire is faulty or there is a bad connection the starter will not work at all, check that wire connection then if all the connections are good then check the starter relay.
 

·
Life Member
Joined
·
5,434 Posts
Try another FOB Battery from another batch and make sure you have it in right side up. My bet is you got a new battery that is not so new.

Had the same problem with member Harleyagain's bike in my driveway. He told me he just replaced the FOB battery and it kept doing it.

I took the battery out of my FOB stuck it in his FOB and bingo, his bike fired right up. His new battery was crap.

Just to double check about the fuel pump not pressurizing I checked all 3 bikes in my garage at the moment and all 3 pressurize the fuel pump with no FOB present, lights were flashing and nothing happens when I hit the starter.

It is worth a try and I hope it is that simple for ya.
 
1 - 6 of 6 Posts
Top