Road Glide banner

1 - 20 of 26 Posts

·
Registered
Joined
·
339 Posts
Discussion Starter #1
Where is the tps on a 2010 road glide and how do you replace it any pics would help
 

·
Life Member
Joined
·
5,434 Posts
Are you sure you are not talking about the CPS (Crankshaft Position Sensor) Item # 7 in the first pic located in front of the Oil Filter or the Twist Grip Sensor Item # 2 in the second pic located in the Handle Bars?



 

·
Administrator
Joined
·
12,480 Posts
If you're referring to the Throttle Position Sensor, I don't believe it exist. You have a TCA, (Throttle Control Actuator), which is the black electric box on you TB, and HD doesn't sell that separately. Do you have a manual?
 

·
Registered
Joined
·
8,826 Posts
What codes are present ?
 

·
Registered
Joined
·
339 Posts
Discussion Starter #5
Thundermax

I DID A TEST ON MY BIKE USING THE THUNDERMAX UCM I SENT THE DATA TO THEM THEY SAID IT LOOKED LIKE I HAD A BAD TPS SO I BOUGHT ONE BUT CANT FIND IT ON MY BIKE I DO A LOT OF MY OWN WORK ON MY BIKE

Throttle Position Sensor Harley FLTRX Custom 2010-2013
 

Attachments

·
Life Member
Joined
·
5,434 Posts
That looks like what was on the bikes with cable controlled throttles but not for a Throttle By Wire bike. Where was it purchased from?
 

·
Registered
Joined
·
339 Posts
Discussion Starter #7
OF COURSE EBAY LOL:confused::eek:
 

·
Registered
Joined
·
339 Posts
Discussion Starter #9
Started

This all started when i came out after eating and the bike had a vibration the local shop said look into the primary i did so and tmax said bad tps so i ordered one i guess the wrong part i have a crank pin runout gauge on theway if i cant find the problem i will pull the cams and tes the crank runout if it is over 3% i will get a new engine instead o fixing this one oh well been riding sense 1963
not the first engine i have lunched haheha
 

·
Registered
Joined
·
8,826 Posts
Are your bars aftermarket ? Any other mods on the bike ?
 

·
Registered
Joined
·
339 Posts
Discussion Starter #11
Bars are mini apes 12" been on bike for years
 

·
Registered
Joined
·
8,826 Posts
You need to get the specs and check the tbw with a meter.
 

·
Registered
Joined
·
339 Posts
Discussion Starter #13
I HAVE FOUND 2010 ROAD GLIDE THROTTLE BODY TBW WITH THE ACUATOR WITH 5K ON IT FOR 100.00 I NEED TOI CHECK THE CRANK RUNOUT FIRST

Pinion Shaft Runout Tool for Harley
 

Attachments

·
Registered
Joined
·
8,826 Posts
Is your throttle smooth and powerful ? Just trying to separate mechanical and electrical problems. Have you replaced your compensator ?
 

·
Registered
Joined
·
339 Posts
Discussion Starter #15
BIKE HAS POWER IDLE IS ROUGH HAVE NOT REPALCED THE compensator PRIMARY IS ALL OK
 

·
Administrator
Joined
·
12,480 Posts
Just out of curiosity, how long have you had this problem, and how long have you had the TMax, have you changed your MAP or done anything else recently?
 

·
Registered
Joined
·
339 Posts
Discussion Starter #17
GOT THE TMAX WHEN I BOUGHT THE BIKE IN 2010
This all started when i came out after eating and the bike had a vibration the local shop said look into the primary i did so and tmax said bad tps so i ordered one i guess the wrong part i have a crank pin runout gauge on the way if i cant find the problem i will pull the cams and test the crank runout if it is over 3% i will get a new engine instead o fixing this one oh well been riding sense 1963
not the first engine i have lunched haheha
 

·
Registered
Joined
·
6,618 Posts
Are there ant DTC's ?
It is highly unlikely that the crank went bad on you when you stopped for lunch,
if the crank was going bad it would have shown signs of it long ago.
My bike shakes like a nun in a whore house when idling and it always has since new so shaking at idle is what the rubber mounted "A" engine does.
Did you check the front motor mount??
 

·
Registered
Joined
·
339 Posts
Discussion Starter #19
I would have never opened up the pimary without checking the normal things like the motor mounts they are all fine the bike has a bad vibration when riding a lot of twin cams get a slipped crank after pumpung up the engine and doing jack rabit starts i do quite a few burnouts by posting here i found out the tbw bikes dont use a tps i will have the runout tool mon or tue if the runoutis good i will replace the throttle body if none of these work it will be off to the shop i am in arizona for 6 months then back to oregon so if no fix take it back to oregon on the 1st of may
 

·
Life Member
Joined
·
5,434 Posts
Good luck with tracking down the issue Joe. Be sure to post back when you get her figured out.
 
1 - 20 of 26 Posts
Top