Road Glide banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 11 of 11 Posts

·
Registered
Joined
·
339 Posts
Discussion Starter · #1 ·
Where is the tps on a 2010 road glide and how do you replace it any pics would help
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #5 ·
Thundermax

I DID A TEST ON MY BIKE USING THE THUNDERMAX UCM I SENT THE DATA TO THEM THEY SAID IT LOOKED LIKE I HAD A BAD TPS SO I BOUGHT ONE BUT CANT FIND IT ON MY BIKE I DO A LOT OF MY OWN WORK ON MY BIKE

Throttle Position Sensor Harley FLTRX Custom 2010-2013
 

Attachments

·
Registered
Joined
·
339 Posts
Discussion Starter · #9 ·
Started

This all started when i came out after eating and the bike had a vibration the local shop said look into the primary i did so and tmax said bad tps so i ordered one i guess the wrong part i have a crank pin runout gauge on theway if i cant find the problem i will pull the cams and tes the crank runout if it is over 3% i will get a new engine instead o fixing this one oh well been riding sense 1963
not the first engine i have lunched haheha
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #13 ·
I HAVE FOUND 2010 ROAD GLIDE THROTTLE BODY TBW WITH THE ACUATOR WITH 5K ON IT FOR 100.00 I NEED TOI CHECK THE CRANK RUNOUT FIRST

Pinion Shaft Runout Tool for Harley
 

Attachments

·
Registered
Joined
·
339 Posts
Discussion Starter · #15 ·
BIKE HAS POWER IDLE IS ROUGH HAVE NOT REPALCED THE compensator PRIMARY IS ALL OK
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #17 ·
GOT THE TMAX WHEN I BOUGHT THE BIKE IN 2010
This all started when i came out after eating and the bike had a vibration the local shop said look into the primary i did so and tmax said bad tps so i ordered one i guess the wrong part i have a crank pin runout gauge on the way if i cant find the problem i will pull the cams and test the crank runout if it is over 3% i will get a new engine instead o fixing this one oh well been riding sense 1963
not the first engine i have lunched haheha
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #19 ·
I would have never opened up the pimary without checking the normal things like the motor mounts they are all fine the bike has a bad vibration when riding a lot of twin cams get a slipped crank after pumpung up the engine and doing jack rabit starts i do quite a few burnouts by posting here i found out the tbw bikes dont use a tps i will have the runout tool mon or tue if the runoutis good i will replace the throttle body if none of these work it will be off to the shop i am in arizona for 6 months then back to oregon so if no fix take it back to oregon on the 1st of may
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #26 ·
What i did

I did a complete cluch adjustment changed rear shocks adjusted the pushrods drive belt vibration seems to be gone but when drving across a manhole bike has a bottom ou feeling will change the fork oil and report back thanks for all your help
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top