Road Glide banner

1 - 9 of 9 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Need some help here... On the way in this morning I noticed a "clank" sound coming from the left side of the engine. It is occurring in gears 2-6 at all RPM's but much more noticeable between 2750 and 3000. It only happens when I'm cruising at about 15-25% throttle and then quickly increase the throttle to pass or speed up. In the moment when I increase throttle, it sounds like a metal on metal "clank - clank" noise coming from the left side. I couldn't tell what cylinder it was, but am guessing the front. It only lasts for a brief moment... but it sure doesn't sound good. Its kind of a "tinny" sound like if you were to take a fork and bang it against something metal. I can reproduce it every time if I back off the throttle, load it up to about 15-25% and then quickly open it up.

Its a 2011 RGU w/ VH 2into1 pro pipe HO and a PCV. I have been trying some different maps in it lately, but I don't think that's the problem.

Any help would be greatly appreciated, freaking out a little here. Thanks MIKE
 

·
Registered
Joined
·
593 Posts
Posability it's some bad gas? Are you using 91+ octane? Sounds like pre-detanation. You'll get it when you load up the engine.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #3
I topped it off this am with 91 (I think), but it only took about 2.5 gallons. That could be it... as I didn't have the problem before this AM. I wouldn't have thought that pre-detonation would have been that loud???

Thanks for your reply. MIKE
 

·
Moderator
Joined
·
878 Posts
It's that loud. Sounds like a rock pinging off the inside of the front fender. Get some Rocket Fuel and add it to the tank. Will help some I think.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #5
Ill run down to the dealership at lunch and get some boost. Do you think the PCV could be doing it? I had Fuel Moto "lean-out" the cruising speeds to up my MPG (i was only getting 30 mpg).
 

·
Registered
Joined
·
42 Posts
DEF sounds to me like detonation. Im not so sure that leaning it out will cause the detonation so much as your MAP and/or timing. Not to mention running anything lower than 91 octane. I NEVER put anything lower than 93 octane in mine. (2011 RGU FLTRX103) I am getting about 40 miles to the gallon right now, completely stock... (roughly 240 miles to the tank) I think im doing my math right anyways? lol... Good luck with it. Let us know how treating the fuel helps.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #7
Thanks for the input. I will put the boost in after lunch... I also just had Keith at fuel moto send me a new map to address the timing issue. Ill post my results.
 

·
Registered
Joined
·
559 Posts
pinging

you might need to take it to someone to tune it on a dyno.if its a clunking noise i have had the compensator nut come loose,makes a lot of noise.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #9
Put the new map on it from Fuel Moto, it was better... But sounded like there was still a ping coming from lower on the engine. It's not nearly as loud. I went ahead and went back to the original map from the beginning because I knew that I didn't have the problem with that map. It was as bad as teh other one, loud ping same as my first post. So that tells me that something has changed on the bike? It never happed before with any of the maps, by now it's happening. So based on the suggestions above, I added some boost... but no improvement. I'm really stuck now, thinking of taking all the maps out to see if it's there with a stock ECM... But don't know. I guess I'm gonna have to get it tuned and let the dealer tell me if there is something wrong, which would be under waranty I'm sure. Just very frustrating. Thanks for everyone's input and let me know if you have any other ideas.. Mime
 
1 - 9 of 9 Posts
Top