Road Glide banner

1 - 12 of 12 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
I had someone clean my air filter (high flow) while installing my Progressive drop ins. The guy made a mess using WAY to much filter oil. I did not notice it at first. oil was all over my motor and rear bag. Now when I give full throttle , the motor cuts of and back on at 3000 rpm and also at 4000 rpm while im full throttle switching gears. cuts off in all gears. I added more fuel at the cut off rpm range but it did not work. Any help out there?
 

·
Registered
Joined
·
1,645 Posts
Why not start with removing the filter, giving it a good cleaning to remove all the extra oil, lightly re-oil and move on. I'm not sure I would have played with any of my fuel settings.
 

·
Registered
Joined
·
6,539 Posts
Why not start with removing the filter, giving it a good cleaning to remove all the extra oil, lightly re-oil and move on. I'm not sure I would have played with any of my fuel settings.
+1^^^^^
I would suspect that the excess oil was burned in the engine and contaminated the front and rear O2 sensors. if cleaning the air filter doesn't help pull the O2 sensors and clean them. If cleaning the O2 sensors don't work you can put new one in, the O2 sensors can be got at any auto parts store I don't have the part number right now but the close loop 18mm O2 sensors for a Volkswagen are the exact same O2 sensors you are using now and they are a direct plug in part.
 

·
Registered
Joined
·
1,066 Posts
+1^^^^^
I would suspect that the excess oil was burned in the engine and contaminated the front and rear O2 sensors. if cleaning the air filter doesn't help pull the O2 sensors and clean them. If cleaning the O2 sensors don't work you can put new one in, the O2 sensors can be got at any auto parts store I don't have the part number right now but the close loop 18mm O2 sensors for a Volkswagen are the exact same O2 sensors you are using now and they are a direct plug in part.

That would have to be a huge amount of oil to damage the o2 sensors. These engine are designed to burn the blow by which is a hell of a lot more oil that comes from a over oiled air filter. You can't clean a O2 sensor.


Connect your tmax to your computer and moniter the o2 sensors. Select AFR . If they are working DON'T replace them.
 

·
Registered
Joined
·
6,539 Posts
That would have to be a huge amount of oil to damage the o2 sensors. These engine are designed to burn the blow by which is a hell of a lot more oil that comes from a over oiled air filter. You can't clean a O2 sensor.


Connect your tmax to your computer and moniter the o2 sensors. Select AFR . If they are working DON'T replace them.
Yes you can clean the O2 sensors, The chemicals in the air filter oil can produce contaminates similar to fuel injector cleaner and T-Max recommends that you don't use any fuel additives because they will contaminate the O2 sensors and throw off the Auto Tune.
Pull the O2 sensors and spray them good with carb cleaner and make sure you spray inside the holes in the closed loop O2 sensor, let them dry out and put them back in the bike, if the O2 sensor hasn't failed then they should work fine. I cleaned my O2 sensors when they screwed up from using fuel injector cleaner and they work just fine.
 

·
Registered
Joined
·
830 Posts
If the burning oil / fouled O2 sensors caused the TM to tune improperly you could just reload your last saved tune....
 

·
Registered
Joined
·
830 Posts
I had someone clean my air filter (high flow) while installing my Progressive drop ins. The guy made a mess using WAY to much filter oil. I did not notice it at first. oil was all over my motor and rear bag. Now when I give full throttle , the motor cuts of and back on at 3000 rpm and also at 4000 rpm while im full throttle switching gears. cuts off in all gears. I added more fuel at the cut off rpm range but it did not work. Any help out there?
You are fixing symptoms instead of concentrating on the problem.
You likely made things worse instead of better. Just clean the air filter and sensors and then reload your last saved tune.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #8
I cleaned air filter as soon as i saw the mess. I reloaded last saved map on my thunder max. I have 09 D& D 2 into 1 headers on the bike. Does any one know what size o2 are? I will try to clean o2 tomorrow and see if it works. I just dont know where to go from here. Thank you for input guy's. More is always welcome
 

·
Registered
Joined
·
339 Posts
From Ironmark
close loop 18mm O2 sensors for a Volkswagen are the exact same O2 sensors you are using now and they are a direct plug in part.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #12
I didn't know the comp would tell if o2 are bad. I will check. I have to learn how to use thunder max tuner
 
1 - 12 of 12 Posts
Top