Road Glide banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Issue with AM/FM radio clarity.

Does anyone have an issue with the clarity of the FM station on the new radio?

I ride with a full helmet and never had an issue on my 2016 FLTRU using the 7 pin connection. I purchased a 2019 FLTRU in November last year and had them put the WHIM in. Ever since I picked it up, there has been static when I listen to the radio. Listening to music thru the phone or USB is clear. I even tried the wired connection, and still there is static. Contacted HD, and there first response was that the dealer was suppose to disable the wired connection when they put the WHIM in.

I took it back to the dealer and they had it for 3 days. There response was there is nothing wrong with the system and the next time it happens to bring it in. When I stated that it happened all the time and was not intermittent they just restated that they could not find anything wrong with the system.

This is BS, I have a $10 portable radio that gets a clearer signal inside a metal building that the new HD radio does.

I have tried two different antennas with the motorcycle out in the open in a area with the engine off and running. No change.
 

·
Registered
Joined
·
1,112 Posts
Mine is fine even with a "The Stubby" antenna. If it was me I'd take a look at all antenna connections. Can't be much else if other forms of music are fine.
 

·
Registered
Joined
·
228 Posts
I have the 2019 Road Glide Standard so I do not have the 7 pin connector but I have the WHIM with the hidden in faring antenna and the Harley branded SENA 20 and I have to say my radio sounds better over Bluetooth on my 2019 than my 2016 did through the 7 pin connector. Something must be wrong with your setup. Besides checking the antenna I would make sure the software on the radio and the SENA are both updated.
 

·
Registered
Joined
·
31 Posts
Issue with AM/FM radio clarity.

Does anyone have an issue with the clarity of the FM station on the new radio?

I ride with a full helmet and never had an issue on my 2016 FLTRU using the 7 pin connection. I purchased a 2019 FLTRU in November last year and had them put the WHIM in. Ever since I picked it up, there has been static when I listen to the radio. Listening to music thru the phone or USB is clear. I even tried the wired connection, and still there is static. Contacted HD, and there first response was that the dealer was suppose to disable the wired connection when they put the WHIM in.

I took it back to the dealer and they had it for 3 days. There response was there is nothing wrong with the system and the next time it happens to bring it in. When I stated that it happened all the time and was not intermittent they just restated that they could not find anything wrong with the system.

This is BS, I have a $10 portable radio that gets a clearer signal inside a metal building that the new HD radio does.

I have tried two different antennas with the motorcycle out in the open in a area with the engine off and running. No change.
My AM/FM/WB reception was great on my 2019 RGS until I switched to a HD fairing antenna (got a tour pack) then it went to the dump mostly when out of the city limits.

I mainly listen through my iphone to Sirius, Pandora, Radio Paradise etc via bluetooth. FM has so many damn commercials I try my best not to listen to it.
 
1 - 4 of 4 Posts
Top