Road Glide banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Yeh, they probably won’t warranty it. Trouble shooting another bike that was having issues. Issues are now passed to my bike. I could pull my amp and stuff and probably get it warranted but it doesn’t feel right when I know it was my own dumb idea. Powers on, sound for about 2 seconds then sound drops to nothing with and without amp. Worked fine before I put it in the other bike to test for if it would power up. Re installed software reset to factory, and reflashed. Still happens. Something was zapped a little. Maybe I’ll tear into it if nobody works on them.
 

·
Registered
Joined
·
2,228 Posts
Radio was put in another bike and turned out without the correct flash for the set up? That’s a thing that can mess up the radio right?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Not really, to get it to operate and run properly you have to do all of those things. When you plug it in without the flash it will say not compatible, but should not affect the overall performance of the radio.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Wow lots of questions here, How did an Issue transfer to your bike ? Did you swap out a part ?
His radio was not powering on, I believe it may be a short in his harness that is causing the issue, now that it zapped my stereo as well. live and learn.
 

·
Registered
Joined
·
824 Posts
His radio was not powering on, I believe it may be a short in his harness that is causing the issue, now that it zapped my stereo as well. live and learn.
Wow could be a pricey lesson, I would in your case take it in for a warranty repair, Bring bike back to stock including speakers and any other audio upgrade.
 

·
Registered
Joined
·
9,177 Posts
1 - 12 of 12 Posts
Top