Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
I have the Biketronics BT2180.14 amp, works great! I added lower speakers, plugged them in, got the bike all buttoned up and everything worked great. Took off on a ride today and about twenty minutes in, the right speakers, lower and fairing, have only static coming out. I did not have the system cranked loud, only about 4 bars on the volume. I did the radio reset, still nothing but static out of the right side. Anything like this happen to any members? Thought maybe I’d check here before taking the fairing off again and tearing into things. Thanks, John
 

·
Registered
Joined
·
2,031 Posts
I have money on the RCA cable. This happened to my set up using the RCA cable that was supplied with my Biketronics kit. I think from vibration the tangs on the plug end get looser and the right channel on mine would come and go. I replaced it with a Monster cable RCA and all has been great. I would pull the fairing and start diagnosing just in case I lost my money and it is not the RCA cable. If the cable looks fine and is still secure, try swapping the channels and see if you get static on the left side now and the right side sounds normal. Good luck, let us know what you come up with or if you need any help.
 

·
Registered
Joined
·
753 Posts
Yep, with both sides going out dollars to doughnuts it's a loose connection. A lot of us are using the 18" stinger 4000 series off Amazon. Nice quality cable, very flexible, inexpensive, and they grab like a bear.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #5
I just happen to have a spare line leveler, so, I will check all the connections tonite, and, if the sound is not restored, I may swap the leveler just to see.
Then, I'll call Biketronics and hope my amp isnt suffering from a blown channel.....
I really don't abuse this system so I hope its an easy fix.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #6 (Edited)
I took the fairing off and initially both rca jacks appeared to be fully seated in both the line leveler and the amp. I pulled the jacks out one at a time, reseated them and turned on the bike. Bingo! You guys were right, the white one (i think) must have wiggled loose as I can’t see where I would have created any ‘pull’ in the wires reassembling my headlight assembly or fairing. I’ve ordered the 18” stinger jacks. Thanks guys!!
 

Attachments

·
Registered
Joined
·
2,031 Posts
I took the fairing off and initially both rca jacks appeared to be fully seated in both the line leveler and the amp. I pulled the jacks out one at a time, reseated them and turned on the bike. Bingo! You guys were right, the white one (i think) must have wiggled loose as I can’t see where I would have created any ‘pull’ in the wires reassembling my headlight assembly or fairing. I’ve ordered the 18” stinger jacks. Thanks guys!!
Glad you got it figured out, sounds so much better when you are hitting on all four speakers I'm sure.
 
1 - 7 of 7 Posts
Top