Road Glide banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
First off two apologies. One I read quite a bit of information on here before posting this but I'm still at a lost to why my alarm is not working.

Two I'm not very good with technology. I tried posting pictures didn't work so I attached the link to the product on eBay. Hope that works.

I hooked the alarm up yesterday and I have to say it is very easy to do there's only one place to connect it and one way for the connection to fit together. It's on a 2011 Road Glide ultra by the way. Anyway after hooking it up. No chirp, no sound whatever. Lights and power and bike starts up great. Lights still flash when I engage and disengage the alarm. Everything seems to be working fine but not the alarm
Any ideas or help would be greatly appreciated. Link to eBay alarm below.
Cameron


Harley-Davidson SECURITY SYSTEM SIREN, SOUND MULTI-TONE ALARM SIREN PROTECTION | eBay
 

·
Registered
Joined
·
7,237 Posts
Cameron is Your 11 Glide equipped with a factory alarm?
If not, I believe the Siren You purchased will not work.
It's for a motorcycle alarm equipped without a siren.
Mike U.
 

·
Super Moderator
Joined
·
12,428 Posts
If your motorcycle has a fob, it should work. One thing to be aware of is the 13 down and 14 up are wired slightly different, make sure you have it for 13 down. On a side note, you can buy that same alarm for a whole lot less. Search for the $6 Radio Shack alarm, even though RS isn’t around anymore in most places, that same piezo siren can be had on eBay or Amazon.
 
1 - 3 of 3 Posts
Top