Road Glide banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2021 HERE!
1 - 13 of 13 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter · #1 ·
I have the DIY air ride with the monroe shocks. Everything has been working fine for the last couple months. On the way to work today I hit a light bump in the road and the rear end dropped all the way down. My air pressure gauge still read 80psi. Pulled to the side of the road and hit the dump switch. There was still plenty of air in the lines. Went to air back up and it took ~3x as long for the bike to start to raise up. It did not start raising until the gauge read close to 140psi. Does anyone have any suggestions on what could have caused this or what could be lose? It seems to me if there was a loose hose the system would be leaking air and the gauge would not be holding pressure?
 

·
Registered
Joined
·
1,756 Posts
No broken eyelets or anything? Does it raise uneven from side to side? Try checking the fittings at the shock input. And if all else fails. Swap out to new shocks.
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #4 ·
I will check them out at lunch. Didn't notice them being lopsided when it raised back up but at the same time I was on the side of 285 during rush hour and was more concerned with not getting run over.
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #5 ·
Got home and pulled the bags. Something doesn't look right here.
 

Attachments

·
Registered
Joined
·
221 Posts
Now I see why people are adding to the welds. Glad you got it home and found the problem.
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #10 ·
Well luckily I have a friend who had a similar issue (His only cracked and leaked) that has a spare from buying a second set. I will put his spare on to get me by for a while and probably order a set of the Gabriels
 
1 - 13 of 13 Posts
Top