Road Glide banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I purchased a 2009 Road Glide. The previous owner upgraded just about everything including having a Hawg Wired system put in. The speaker select switch no longer does anything. A powered antenna was also installed.

The problem I am having is everything works fine except the AM/FM radio. It's a stock Harley radio. The CD and AUX works fine when the bike is on. The AM/FM radio is just static. When I turn the ignition to ACC, the AM/FM radio works???? It's all fine and good except I can't really ride down the road with the ignition in ACC.

As far as I can tell, the main radio harness was not cut.

Any ideas??????
 

·
Registered
Joined
·
4,039 Posts
Are the headlights HID's by chance? HID's are known for radio interference but if it's not that look for another source of electrical interference. I would say that the antenna was not hooked up properly but since you said it works on ACC it may not be that.
 

·
Registered
Joined
·
413 Posts
Is there any chance that the powered antenna is only getting power with the switch in the ACC position?

tom
 

·
Registered
Joined
·
317 Posts
I have the exact same issue. I have the LED headlights that drop in place of the old bulbs. They have fans driving to cool things down. I am thinking the two might be related but so far nothing found. HD just rubs their chins and say HUM???. I'll be watching this thread closely in case a solution is found. Headlights come on in "Ignition" position, but are off in "Access" position. Was thinking of pulling the Headlight fuse and see if the radio changes any
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Am/fm

Yes, I have the upgraded lights as well. On a hunch, I pulled the headlight fuse and **boom**, it works as advertised. I see the ballast for the lights is a small unit they mounted on either side of the radio. I'm going to try re-locating them to see what happens...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Am/fm

Ok...if I pull the headlight fuse, the radio works. If I put the fuse back in and move all the headlight related stuff, the radio does not work on either run or acc???

If I put all the light stuff back, I get radio back only in the acc position again.

Also, if I turn off the radio, as soon as I turn to run, i get static and a faint beep beep beep beep sound over the speakers, on acc, only quiet static???

Dear God.....shoot me now...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
I give...

So......I went all last season without using my radio. I have my scoot ripped apart for the winter and tackled this again.

I took apart the entire front end and stretched out ALL the headlight wires, components etc. With all the headlight crap 4 feet out in front of the bike, and the headlight system not grounded, radio works fine. As soon as I attach the grounds, even using a separate wire away from the bike all the way back to the neg on the battery, the radio goes all static...

The only wire/wires running anywhere near the stereo system is the power. I am wondering if shielded power wires are the answer????

I guess it's another season of iPod.....
 

·
Registered
Joined
·
225 Posts
Might check at a vehicle radio install place. There are several isolation products that are cheap and work if you know what to use. I had a similar problem with my boat and less than $50 later I had an isolation transformer and a coil suppressor that solved all my issues. What they technically do I have no idea, but the tunes now flow so life is good.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12 (Edited)
Well...score one for the good guys...

Pulled the lighting system power wire out of the bike and ran it external...totally works as advertised. Put it back where it was (along side the stereo power) and BOOM...static when energized.

Ran the lighting system power still under the tank but on the opposite side as the stereo and all is well!!!!

I'm still going to replace the lighting syetem power with a shielded wire but that was certainly the problem....
 
1 - 12 of 12 Posts
Top