Road Glide banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2022 HERE!
1 - 12 of 12 Posts

· Registered
Joined
·
4,692 Posts
Discussion Starter · #1 ·
Just small example why this forum is great.
The other day I was out riding and all of a sudden at idle & low RPM's my bike started squeaking/chirping really bad, WTF. So I took it home and could not pin point where it as coming from. It sounded like it was coming from the engine, like maybe engine mounts. So before I drove myself nuts trying to figure it out I looked it up on the forum, and from what I read most of the time it's the Rubber muffler mount. Sure enough mine had shifted forward, in some cases it's a dry mount that needs a squirt of lube. Saved me the time trying to figure it out, it didn't sound like it was coming from the rear. I read some posts on guys who basically tore the whole bike apart trying to find the source.
So thanks to those who share ideas/ tips to save others from the time and hassle they went trough.
 

· Registered
Joined
·
654 Posts
So, just so I understand. It was the rubber muffler mount that the slip on muffs are bolted against under the saddle bags?
 

· Registered
Joined
·
498 Posts
Oh man! I wish I'd read this sooner. I've been going nuts tracking down a weird squeak.

 

· Registered
Joined
·
498 Posts
No, it's getting new paint and powder, as well as a couple of upgrades.
 

· Registered
Joined
·
99 Posts
Mine does the same thing occasionally with my 2-1 Dragula, sometime pushes the rubber right out of the mount. Might try some synthetic o-ring lube next.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top