Road Glide banner
1 - 20 of 43 Posts

·
Registered
Joined
·
1,427 Posts
Discussion Starter · #1 ·
So many of you that browse the audio section know I'm having some totally goofy undiagnosed audio issue.

I was just checking fuses and battery hot/ground under the seat. Put it together.

Now my ABS light is on. I checked the codes. I'm getting:

U1040
C1095
C1216
C1095

The c1095 and c1216 appear to be from open brake light switches. I'm guessing that's from when I changed levers.

I cleared all codes. The abs light stayed on. The U1040 came back and the c1055 popped up.

No check engine light. Bike runs fine.

I still haven't recovered from the $4200 dollar leak, so dear god I don't wanna go to the dealer.

Can anyone please help?
 

·
Registered
Joined
·
1,427 Posts
Discussion Starter · #3 ·
Thanks.


Next possible cause;

With my stereo issue and now abs issue, could this be a battery? I ask because the vokts are reading low. About 14 while riding and 11 when stationary. Could a bad battery explain the abs and stereo? Is the bike cutting out uneeded things?
 

·
Registered
Joined
·
3,545 Posts
Thanks.


Next possible cause;

With my stereo issue and now abs issue, could this be a battery? I ask because the vokts are reading low. About 14 while riding and 11 when stationary. Could a bad battery explain the abs and stereo? Is the bike cutting out uneeded things?
Didn't see your other thread but if a battery is low and you have an amp it will go into protect mode and cut off when the battery is low.
 

·
Registered
Joined
·
10,385 Posts
11 volts on a battery is low. Try starting it, and measure it while the engine is turning over. It should hold at about 10 volts. Running it should be up around 14 volts.
 

·
Registered
Joined
·
1,427 Posts
Discussion Starter · #12 ·
Yeah the brake lights still work properly and those codes didn't come back. I'm still getting the c1055 code which seems to mean ECU internal failure. I don't know exactly what that means, but it sure sounds expensive....

I'm really hoping it's just the battery, voltage regulator, or stator and one fix cures my ABS and stereo issues.

The abs light does go away while riding sometimes, usually at high speed high rpms.
 

·
Registered
Joined
·
1,477 Posts
this is a stretch but did you try pulling the main fuse for a few minutes?

do you have a power vision or a tts? if its a power vision that you bought from fuel moto try giving jaimie a call.

it does also seem like battery has some effect, I would pull the battery and have it load tested.
 

·
Registered
Joined
·
1,427 Posts
Discussion Starter · #14 ·
I'll try main fuse. Gonna pull batt for load test.

HD dealer thinks abs issue is unrelated. Sure is weird timing though. Thinks it could a pinched wire, bad connection, wheel sensor, or wheel bearing.

Trying not to take it there.
 

·
Registered
Joined
·
1,477 Posts
I'll try main fuse. Gonna pull batt for load test.

HD dealer thinks abs issue is unrelated. Sure is weird timing though. Thinks it could a pinched wire, bad connection, wheel sensor, or wheel bearing.

Trying not to take it there.
and they will fix all of those things for you just in case it "might" be broken. They are so kind to you.
 

·
Registered
Joined
·
461 Posts
Looks like you should trade her in... Sounds like you own a boat, not a bike :eek:.
 

·
Registered
Joined
·
1,636 Posts
please keep your bike far from my bike.

+1 on that! I dont think you parked near my bike anytime during our M&G the other week, whew!

Kyle, sure is a run of bad luck you are having. I can not offer anything other than what was already stated to try. I can tell you that when my battery died last summer when I was in Gettysburg for bike week, I was experiencing some tough starts (wondering if it was going to start or not), then I pulled in for gas on my way home, filled up and hit the starter button and nothing! I had no other indicators that lead up to it with any indicator lights or radio function as you are mentioning. Hope this gets better for you.
 
1 - 20 of 43 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top