Road Glide banner

1 - 4 of 4 Posts

·
Registered
Joined
·
293 Posts
Discussion Starter #1
I have a nice 2011 FLTRU and want to install a simple Garmin that mounts to my windshield. I have the mount and the carriage to mount my nuvi 550 but cannot seem to get 12VDC for it. It works just fine there without power from the bike. I tried the dealer since it had a reversed polarity on the cigar lighter but to no avail, even after that was corrected the thing refused to play. It works just fine on the charge it gets while plugged into my PC but refuses to play with the HD power supply. I thought maybe the power adapter was at fault but it works great in my car using the cigar lighter there, before and after I had HD troubles with it. The adapter is stamped with a power rating that says it draws under 1 amp DC but even with the 15 amp fuse, seems to be the HD standard, it blows the fuse every time I energize the circuit. How the heck do I get my Garmin to play nice with the Road Glide?
I have started to consider installing a single purpose power supply socket but that seems so very wrong. Any vehicle manufacturer should be able to supply a simple 12V power source, at least in my opinion. My dealer has failed me so far and I will not hesitate to say they are totally inept if they can't resolve something so simple.
 

·
Registered
Joined
·
1,179 Posts
That sounds confusing if it works in your car but blows fuses on the bike...but the only thing that makes a fuse blow is because the GPS (or its wiring) is trying to draw more current than the fuse is rated for. That usually happens when the positive side accidentally contacts the ground side. This can happen through a reversed connection, pinching a wire, breakdown in the insulation on the wire, etc. You get a dead short and the fuse blows.


Now then...You mentioned the dealer changed the polarity of your lighter. You should confirm that the center contact of your lighter socket is positive and the outside metal sleeve is connected to ground and by "confirm", I don't mean ask the dealer, I mean check it yourself with a multimeter. Then recheck the GPS power connection to be sure it's correct as well. I'll betcha you find one of those reversed.
 

·
Registered
Joined
·
293 Posts
Discussion Starter #3
I had the dealer check it because I had found it reversed using my own meter. I have yet to check that it got more than sun time though.
 

·
Registered
Joined
·
293 Posts
Discussion Starter #4
Went back and checked. The polarity is right now but the darned thing still doesn't work. I have no idea why. The voltage is good at a bit over 14V when the bike is running, the polarity is right and the Garmin still refuses to play, but only on the bike. It works fine in any of my cages.
I found a nice hard wire solution on Amazon for about $13 that will let me direct wire to the auxiliary switched wire and get the right voltage for my Garmin. When it arrives I will wire it to the auxiliary wiring under the seat, run it to the left side glove box and place the voltage adapter in there. It is a short trip from that to the mount itself and, using the Aux switch, I will be able to control power availability to the Garmin.
Let's hope it works out in the real world as well as it does on paper. From what I have found the orange to the aux plug is the switched hot and the black is ground so we shall see if that works out.
 
1 - 4 of 4 Posts
Top