Road Glide banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2022 HERE!
1 - 2 of 2 Posts

· Registered
Joined
·
1,390 Posts
What year Bike? (My '09 did the same thing when I got it in '12~pipe & FuelPak) I don't know if my Dealer "flashed" the ECM or not... since you are mentioning the issue after installing the 124 and PC-V, I doubt it's in the ECM / TBW...

Where did you get the Map from?

Dyno Tuned?


Something to try, won't hurt anything;
Plug the PC-V into the laptop, if there are any values other than "0" in the "0"% Throttle Position Column, then set all values to "0". I have been told to do the same thing in the 10% Column also, but did not do so, since zeroing out the "0" Column solved my issue with the 117

Congrats on the 124!!!
 

· Registered
Joined
·
1,390 Posts
Yeah I am considering it. More and more I am leaning to going with something else. Love the power commander but it never seems to get dialed in right on the bigger motors. 6 months ago I would have told you that you were nuts and that power commander 5 was awesome.
'Not saying that the PV-V is the greatest thing since sliced bread, since I have one on the 117 and it works great, 18k+ miles, responsive power everywhere, 35-38 mpg around town / playing on the back roads, 40+ Interstate all 2-up loaded.

I'm not one to think "my components are better than yours" LOL

'just throwing a couple things out there before you drop more bucks for a Tuner / Dyno, and could still have the same issue. The bog could be related to the TBW / ECM? (my '09 had the same bog stock) I would want to make sure that the PC-V is the culprit before getting off the hip$

My ramblings in no particular order;

Have you unplugged the harness from the Throttle Body and made sure all is as it should be? No corrosion, bent pins, etc...

You might give DynoJet or FuelMoto tech support a try (if you haven't already?) and see what they have to say (eliminating the PC-V as the culprit). DJ TS is probably at Sturgis now :frown:

Check with Dealer and see if HD has any "Flash Updates" available for your ECM.

Ask your Dyno Guy (the 2nd Tune) what he thinks?

Or if you're fed up at this point with the PC-V and decide to go with another Tuner / Dyno guy, I would bring up the issue on the initial "interview" and have an understanding that his product will eliminate this issue...

Good luck, Keep us Posted...
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top