Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am hoping someone can help me. I have a 2015 RGS with Boom audio stage II dealer installed when I bought the bike. I haven't had any issues with the stereo since. Then the other day I got on the bike and noticed only the left speaker seemed to be putting out any sound. I got home and pulled the nose of the fairing off just to check for loose wires but found nothing loose but did notice that the right speaker was barely working but definitely not as loud as the left one. Has anyone else had this issue?
 

·
Registered
Joined
·
5,312 Posts
I am hoping someone can help me. I have a 2015 RGS with Boom audio stage II dealer installed when I bought the bike. I haven't had any issues with the stereo since. Then the other day I got on the bike and noticed only the left speaker seemed to be putting out any sound. I got home and pulled the nose of the fairing off just to check for loose wires but found nothing loose but did notice that the right speaker was barely working but definitely not as loud as the left one. Has anyone else had this issue?
Can you hear anything out of the tweeters? Did you try swapping the speakers from side to side to see if it's the speaker or the amp? If the trouble stays with the speaker, it's the speaker. If the trouble stays on the right side, then it's the amp.
 

·
Registered
Joined
·
1,709 Posts
no Boom II, but my right speaker rattled this morning like it was blown and then quit producing sound. tried it on the left still no sound.
 

·
Registered
Joined
·
136 Posts
I am hoping someone can help me. I have a 2015 RGS with Boom audio stage II dealer installed when I bought the bike. I haven't had any issues with the stereo since. Then the other day I got on the bike and noticed only the left speaker seemed to be putting out any sound. I got home and pulled the nose of the fairing off just to check for loose wires but found nothing loose but did notice that the right speaker was barely working but definitely not as loud as the left one. Has anyone else had this issue?


Shoot me a PM and provide your email and the make model of your bike and I will see if I have that manual. I’ve pretty much got everything from 1925 current. They aren’t hard to diagnose when you have a Harley manual.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Update:

Update... Took it in to the dealer today.I was hoping it was a speaker but it was not. It turned out to be the amp of course. The service tech told me that the early boom audio amps (2014-2015) had some minor bugs but that he thought the newer amps were better. so they installed a new amp and it is working like a champ. Thanks for all the help and tips on this issue. :grin:
 

·
Registered
Joined
·
1,311 Posts
Update... Took it in to the dealer today.I was hoping it was a speaker but it was not. It turned out to be the amp of course. The service tech told me that the early boom audio amps (2014-2015) had some minor bugs but that he thought the newer amps were better. so they installed a new amp and it is working like a champ. Thanks for all the help and tips on this issue. :grin:
Oh great.....LOL:eek: I too, had the Boom upgrade on my 15 before I took delivery. Only problems, so far, is blowing left side speaker in my lower fairing. Extended warranty takes care of it, with me paying $50 deductible. Next time, Iam thinking I'll go aftermarket speakers
 
1 - 6 of 6 Posts
Top