Road Glide banner

1 - 15 of 15 Posts

·
Registered
Joined
·
654 Posts
Discussion Starter #1
I recently purchased a 2006 RGC. Great bike so far. Today I used the cd player first time. The player liked Eric Church so much it won't give it back to me. In fact I can't get the radio control to highlight the cd function of the sterio. Seems to toggle from AM to FM , skips cd function and goes straight to WB. Any ideas to highlight the cd function of the oem HK sterio? Thanks
Grambo
 

·
Administrator
Joined
·
10,358 Posts
it is a reading problem IIRC

I have herd of several solutions with mixed results

1) ride a few blocks with the CD dust cover open , bumps will eject it

2) pull maxi fuse for a few minits to reset the radio

3) disconnect battery and try after reconnecting

4) pretty certain if you force fully remove the CD , the radio is done

JtB
 

·
Registered
Joined
·
654 Posts
Discussion Starter #3
Thanks Jack. I will definitely remember not to forcefully yank the cd. The other suggestions I will try, then might look for a 2013 sound system.
 

·
Registered
Joined
·
654 Posts
Discussion Starter #5
Kind of all ready tried that. Gonna try disconnecting to battery first.
 

·
Registered
Joined
·
745 Posts
The cd player in my truck will not eject a cd. I hold the eject button and reach in with a pair of hemostats and remove the cd. Has no ill effect on my truck radio/cd player. Stick another cd in and rock-n-roll....Not saying this will work on your system but it works in my truck...
 

·
Registered
Joined
·
654 Posts
Discussion Starter #7
So push and hold eject button and pull out CD. Will put it on my list of remedies which I will try Monday or Tuesday. Though I find it interesting that I can not highlight the CD function on the sterio when toggling through the sterios functions.
 

·
Registered
Joined
·
2,127 Posts
The cd player in my truck will not eject a cd. I hold the eject button and reach in with a pair of hemostats and remove the cd. Has no ill effect on my truck radio/cd player. Stick another cd in and rock-n-roll....Not saying this will work on your system but it works in my truck...
Unless you adapted a Harmon/Kardon radio to use in your truck, that may not work.
The CD should not forced out of the H/K radio. It can damaging the radio.
The original poster should contact Iron Cross Audio for advice. They are good guys and will help.
 

·
Registered
Joined
·
745 Posts
Unless you adapted a Harmon/Kardon radio to use in your truck, that may not work.
The CD should not forced out of the H/K radio. It can damaging the radio.
The original poster should contact Iron Cross Audio for advice. They are good guys and will help.
I said it was a truck radio/cd player and it might not work on his...Maybe you should pay closer attention to what you are reading.
 

·
Banned
Joined
·
845 Posts
My 2013 road glide ultra has the same problem! Im waiting closer to 2015 to warranty it and get a new unit before it expires



"If the opposite of pro is con, then that means the opposite of progress is congress"
 

·
Administrator
Joined
·
12,448 Posts
My 2013 road glide ultra has the same problem! Im waiting closer to 2015 to warranty it and get a new unit before it expires



"If the opposite of pro is con, then that means the opposite of progress is congress"
It doesn't matter if you wait, they're still going to give you a refurbished unit, so you might as well get it done soon to make sure you get a good unit, IJS, personally I'd take it as an opportunity to get rid of the HK. OP I'm glad you removed the cd, you might want to stick another one in while you have it apart to see if the problem persists.

Sent from my SPH-L710
 

·
Registered
Joined
·
3,265 Posts
My 2005 FLHTSEI2's ,....had the same problems!!!
I do believe , either way , the Radio's are J-U-N-K!
Whether ya find,.... Hemostats that work, unplug whatever , to reset ,....or call Iron X, ur still gonna have to pull it to fix it! Ya mite even have to pull it again, and again, and again!??? But I do believe the Warranty has X-Pired, so,....Just pull it and stick an M-80 in it!
Hmmmmm, ask me How I Know!
hehe-hehe
 

·
Registered
Joined
·
2,127 Posts
My 2005 FLHTSEI2's ,....had the same problems!!!
I do believe , either way , the Radio's are J-U-N-K!
Whether ya find,.... Hemostats that work, unplug whatever , to reset ,....or call Iron X, ur still gonna have to pull it to fix it! Ya mite even have to pull it again, and again, and again!??? But I do believe the Warranty has X-Pired, so,....Just pull it and stick an M-80 in it!
Hmmmmm, ask me How I Know!
hehe-hehe
Your radio is not an Harman/Kardon radio, as the OP.
The radio in the 2005 model year is from Radio Sound.
2005 was the last year for Radio Sound.
 

·
Registered
Joined
·
654 Posts
Discussion Starter #15
Just hit with your elbow and say EHHHHHHH!
Well Shawn was right. Ehhhhhh. Fixed. Went for a ride Sunday, a few bumps must have moved the cd a little, cd now working the way it is supposed to.
Grambo
 
1 - 15 of 15 Posts
Top