Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter #1
I have a 2012 FLTRU with 66k miles. After riding about an hour, the engine and battery lights come on. Volts are okay, no riding issues. When I stop, turn off the engine and restart the lights are gone. But, will come back on after an hour or so of riding. Going to a friends house tonight to check what codes are registering, but I want to check in here to see if anyone else had this problem.

Thanks!

Jeff
 

·
Registered
Joined
·
400 Posts
Lots of problems with voltage regulators. 12's had a recall. Lots of 13's have had regulators/staters replaced under warranty. Do a search and you will find a lot of information on the topic.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
7,261 Posts
What are the codes that set?
 

·
Registered
Joined
·
120 Posts
Discussion Starter #4
What are the codes that set?
Engine light and battery light came on last night when I got home. I turned off the engine and put the bike into the diagnostic mode. Went through each section, no code.

When this first happened, I got c1095, front brake switch open. But I am not sure that the battery light would come on.

Thanks.
 

·
Registered
Joined
·
120 Posts
Discussion Starter #5
If anyone cares, the entire charging system had to be replaced. New stator, compensator and volt regulator was installed. Thank goodness for the extended service plan. No fuss, dealer did the work in one day. Hats off to Old Road Harley Davidson in Santa Clarita, CA.
 

·
Registered
Joined
·
7,261 Posts
Glad it got taken care of
 
1 - 6 of 6 Posts
Top