Road Glide banner

1 - 11 of 11 Posts

·
Registered
Joined
·
305 Posts
Discussion Starter #1
On the way home from work yesterday, I noticed a chirping sound whenever I went over "bumbs" in the road. Nothing severe, it wasn't like I was running through potholes. Has anyone else experienced this?
 

·
Registered
Joined
·
1,361 Posts
Check your belt tension. A "too tight" belt can cause chirping.
 

·
Registered
Joined
·
1,228 Posts
Also check your muffler clamps and heat shields. A buddy of mine had the same thing, got to the point that it was scary to ride because it made so much noise. We took the slip-ons off re-installed them and retightened the heat shields, finally got it...
 

·
Registered
Joined
·
17 Posts
Check the muffler hanger brackets that hold up the rear of the muffler. There is a rubber bushing in there that dries up and can cause "chirping" noises. Just grease it up a little and you should be good to go.
 

·
Registered
Joined
·
526 Posts
Mine was a loose baffle in my slip-ons...a few turns with the allen wrench..no more "chirping" noise....Hopefully its something simple like that for you :)
 

·
Registered
Joined
·
715 Posts
You may want to check if you have a parakeet stuck between the forks and the front brake caliper. I did going to Sturgis last year, but it was dead!
 

·
Registered
Joined
·
8,225 Posts
+1 on the muffler clamps,.. mine still does it every once in a while on the right side.
 

·
Registered
Joined
·
305 Posts
Discussion Starter #11
I'll give the Virtual Mechanic Award to Stryke1. It was the rubber bushing on my right exhaust. It had not dried out but it did slide out of place.
 
1 - 11 of 11 Posts
Top