Road Glide banner

1 - 11 of 11 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Lighter itself is not working. Just bought the bike new, so don't know if it has ever worked. Any ideas if it may be any easy fix, i.e. a fuse, or something that the fairing may have to come off for?
 

·
GONE BUT NOT FORGOTTEN
Joined
·
2,338 Posts
Check the fuse first...... if that's not it, open the fairing..... if that's not it, stop smoking :D
 
W

·
Guest
Joined
·
0 Posts
Mine didn't work either when I bought my bike. Pulled the fuse cover to discover that they didn't put one in at the factory.
 

·
GONE BUT NOT FORGOTTEN
Joined
·
1,775 Posts
Are you checking it with the ignition off? just sayin'. Ignition has to be on for it to work.
 

·
Registered
Joined
·
1,179 Posts
After re-reading his first post, I'm not sure whether he means the socket has no power or the lighter doesn't get hot.
 

·
Registered
Joined
·
955 Posts
If you just bought the bike new take it back to the dealer and have them correct the problem. If you haven't had your 1k service done yet, you will soon. Just have them look at it.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #10
No power. Will check owners manual for fuse location. Wasn't sure if there was a dedicated fuse for the lighter. As best i can tell, it is the only thing not working...
 
W

·
Guest
Joined
·
0 Posts
No power. Will check owners manual for fuse location. Wasn't sure if there was a dedicated fuse for the lighter. As best i can tell, it is the only thing not working...
There definitely is a dedicated fuse. It is a Blue colored fuse.
 
1 - 11 of 11 Posts
Top