Road Glide banner

1 - 5 of 5 Posts

·
Registered
Joined
·
629 Posts
Discussion Starter #1
I remember reading a long time ago on here about the bolts holding the transmission cover over the exhaust bracket coming loose.
Tonight I was doing a "pre flight" before my trip to the mountains, and I noticed a little film of oil on the exhaust bracket...
Sure enough, the two transmission cover bolts that also hold the bracket were finger tight at best...
tightened them as best I could with little allen wrenches, but could not do it properly because I did not have a deep socket to take off the exhaust nut. Will fix properly tomorrow (after I ride to Sears for some deep sockets).
Lesson learned- everyone check your bolts! (and nuts) :p
Ian
 

·
Registered
Joined
·
83 Posts
Took mine in for it's 24k service on Friday, I had noticed the night before a small film of oil on the bracket but since I was taking her in the next morning for servicing... I didn't look hard to see where it was coming since it was such a small amount.
Told them about the oil and when I picked her up later that day they mentioned that those 2 bolts were missing and were the cause of the leak. Apparently they check these all the time because of the known issue with these bolts.
I'm gonna keep my eye on these from now on.

Shut up & Ride!
 

·
Registered
Joined
·
144 Posts
I had a small amount of oil under my xmsn at first I thought it was the drain plug, that the last time had it in the broke or did not tighten well.
They told me it was that bracket. It is good to go now. had a buddy with a limited and it did the same thing.
So if you have a small spot of oil under your bike check the bracket
 

·
Registered
Joined
·
59 Posts
Took mine in for it's 24k service on Friday, I had noticed the night before a small film of oil on the bracket but since I was taking her in the next morning for servicing... I didn't look hard to see where it was coming since it was such a small amount.
Told them about the oil and when I picked her up later that day they mentioned that those 2 bolts were missing and were the cause of the leak. Apparently they check these all the time because of the known issue with these bolts.
I'm gonna keep my eye on these from now on.

Shut up & Ride!
Had the same thing happen to me. Went out the other morning and oil on the carport under the bike. Looked and found that the bolts were missing from my bracket also. Got some more from the dealer and put lock tight on them. Will be checking from now on.
 
1 - 5 of 5 Posts
Top