Road Glide banner

1 - 10 of 10 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1
I just had my inner fairing painted, and the clutch cable is rubbing and scratching the speedo housing. The cheap plastic cable holder doesn't work and so my new paint job Is scratched. Any suggestions on keeping the cable off the paint? Thanks.:confused:
 

·
Registered
Joined
·
144 Posts
Discussion Starter #3
I have one of those already installed and doesn't help up top. When you turn the bars, the cable rubs, especially to the left. Maybe I don't have the clamp installed correctly?
 

·
Registered
Joined
·
144 Posts
Discussion Starter #5
A couple questions. What year is your bike? Is your cable clamp above the rubber cover that looks like a shock cover, or beneath it. Might is down low beneath the rubber cover. I put it where I cut the zip tie HD had tied the cable to the frame. Thanks.
 

·
GONE BUT NOT FORGOTTEN
Joined
·
3,813 Posts

·
Registered
Joined
·
7,202 Posts
I dont have it painted but like mentioned before turn the plastic clip around. I had to flip the clip and been using it that way for 2 years. No rubbing either
 

·
Registered
Joined
·
1,812 Posts
My clutch cable wants to migrate away from my speedo housing. I used a zip tie to hold it. In your case, you could make a stand off by running a zip tie thru a washer on the inside of the speedo, and then both sides of the tie thru a black fuel line cut to length, and around the cable. I bet it would blend in. I used that method to temporarily mount my lowers. It's been 2 years now, and I never did fix them.
 

·
Registered
Joined
·
4 Posts
I just bought a good quality black (plastic?) coated clamp from the local hardware store that was a larger diameter than the cable and attached it using the existing screw on the speedo cover. The cable can move freely and it doesn't rub!
 
1 - 10 of 10 Posts
Top