Road Glide banner

1 - 10 of 10 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter #1
During a 350km ride today, the clutch pull at the lever was harder than normal and felt like the lever pin was siezing. Lever felt rough in my fingers. Got it home and checked. The lever pin is fine. Rough lever pull and a noise i would call a mix of grinding and squeaking coming from the right side cover. My dealer said first time they have seen it. Anybody else? My bike is having a sleep over til they can look at it Tues morn. Thanks all.
 

·
Registered
Joined
·
2,326 Posts
I do not have any input for you, but I wish you luck in getting it resolved and let us know what the issue/repair was.
 

·
Registered
Joined
·
119 Posts
During a 350km ride today, the clutch pull at the lever was harder than normal and felt like the lever pin was siezing. Lever felt rough in my fingers. Got it home and checked. The lever pin is fine. Rough lever pull and a noise i would call a mix of grinding and squeaking coming from the right side cover. My dealer said first time they have seen it. Anybody else? My bike is having a sleep over til they can look at it Tues morn. Thanks all.
Did you check your fluid levels? A few M8s have been transferring trans fluid to the primary.
 

·
Registered
Joined
·
166 Posts
Discussion Starter #7
Sorry all life got busy. Dealer said factory didnt lube o rings correctly in the secondary slave but i have my doubts. I dont trust my dealer service department very much. They are going to update my oil pump as well. When i brought up my fluid transfer issue the service manager got angry and told me it was physically impossible. When i said all the HD sites out there are talking about it he said its all lies and if I asked any of his techs it doesnt exist. I brought up TA 0022 and told his counter guys either he doesnt what he's doing or hes a liar, two choices. Then I walked out.
 

·
Premium Member
Joined
·
3,086 Posts
Sorry all life got busy. Dealer said factory didnt lube o rings correctly in the secondary slave but i have my doubts. I dont trust my dealer service department very much. They are going to update my oil pump as well. When i brought up my fluid transfer issue the service manager got angry and told me it was physically impossible. When i said all the HD sites out there are talking about it he said its all lies and if I asked any of his techs it doesnt exist. I brought up TA 0022 and told his counter guys either he doesnt what he's doing or hes a liar, two choices. Then I walked out.
I can't believe there are still dealers with the balls to say fluid transfer isn't a real issue. Another guy said the same thing on a different thread about a week ago. What do you have to gain by lying?!?!
 

·
Registered
Joined
·
166 Posts
Discussion Starter #9
They checked and confirmed levels when it was there. When its low im going to request they check it in front of me, the service manager and the sales manager who is a friend of mine. Then we go to the manager and Harley Canada rep to complain about the issue and the service manager. I'll remind them i am a certified commercial transport tech, heavy duty tech and cummins engine certified so i pretty sure i know how to check f'n levels according to the service manual i own. Sorry to rant. Just pisses me off!!
 

·
Registered
Joined
·
487 Posts
I will be keeping a close eye on my 2018 RGS for this issue.
 
1 - 10 of 10 Posts
Top