Road Glide banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a 2007 Road Glide in which I began to adjust the clutch cable (after 6000 miles noticed a little extra play) loosened cable adjustment, removed derby cover, backed out screw, tightened until just bottomed and then backed out 3/4 turn....seems normal and a he_ _ of a lot easier than my shovel. I then went to adjust the cable and wooha! It adjust almost all the way out and still more than an 1/8 play at lever.
**My issue....I have heard someone mention that the clog inside the "Clutch Release Cover" can become inverted but not clear if the end issue would be the same as mine.

Thinking the clutch disks may have been to worn, I replaced the clutch assembly with a Barnett Scorpion Assembly, nope...not the disks, still way to much play in cable.

**Does this sound consistent?

Thanks, Enjoy the Holidays!
Harry:confused:
 

·
Registered
Joined
·
974 Posts
Maybe try and back the adjuster a 1/2 turn out then adjust the cable. See if that helps out some. On my old FLHT, I had an extended cable due to the reduced reach bars, and the proper adjustment on that one left the cable right at the very end of the threads.
Lil Chief
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Thanks, this has ape hangers, the length of cable has been fine for the three years I`ve owned the bike. The extended length only became an issue with this adjustment. I installed and Energy One set of disks and diaphragm spring with great results, I could get neutral at a stop with bike running. All other adjustments (3) no issues, that`s why I puzzled.
Thanks Again,
Harry
 
1 - 4 of 4 Posts
Top