Road Glide banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
2016 FLTRXS, 7500 miles. Bought in December 2015, first failure was May 2016 all instruments quit working, ECU changed, September 3rd 2016 I started bike and low fuel icon was blinking yellow and L RNG was in the odometer window at next stop light all instruments dead. Bike is at dealer waiting on Milwaukee to advise. Anybody else seeing this type of issue?
 

·
Registered
Joined
·
4,189 Posts
Yup. Mine is in the shop right now waiting on a new dash. A mile from my house on the way to work. No lights on the dash. All gauges dead. Fuel on E. Volt meter on 0, speedo at 60 and tach at 1900.

I should have thought to upgrade to the CVO gauges. But. Too late.
 

·
Registered
Joined
·
17 Posts
2016 FLTRXS, 7500 miles. Bought in December 2015, first failure was May 2016 all instruments quit working, ECU changed, September 3rd 2016 I started bike and low fuel icon was blinking yellow and L RNG was in the odometer window at next stop light all instruments dead. Bike is at dealer waiting on Milwaukee to advise. Anybody else seeing this type of issue?

I lost all of my gauges and indication on my 2016 FLTRXS after riding in a bad rain storm. Long story short.... they replaced the tach/speedometer cluster and all is well. Went to Sturgis and experienced a lot of rain and hail and it continued to work. I submitted a complaint to NHSTA for this but haven't heard anything back. Harley claimed to no nothing of the problem but you are the 8th person that has had the issue, and that doesn't take into account those that don't use the forums.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
I misstated. ECU wasn't changed, Instrument cluster which has brains it was changed back in May, today on the advice of Hd Milwaukee they changed it again. Now I want to know how long they will keep doing it for free, I cant seem to find anywhere online the warranty details. Someone told me if it was identified during the warranty period its always covered. I aint buying that.
 

·
Registered
Joined
·
4,189 Posts
I had some warranty work done on my 08 just before the warranty was up. The part failed 6 months after the warranty expired. They fixed it. No cost. That's not to say another dealer would. But in my experience the statement is true.
 

·
Registered
Joined
·
8,246 Posts
I wonder if any changes were made on the M8's?
 

·
Registered
Joined
·
3,968 Posts
Someone told me if it was identified during the warranty period its always covered. I aint buying that.

This only applies if you have the issue again within the warranty period and can't get an appointment or get it in to the dealership until after the warranty expires. Dealerships have gone to bat for the customer and still been able to get things covered if it has been a historical problem but usually once they have deemed to have fix the issue it's a whole new claim after that.


Sent from Motorcycle.com Free App
 
1 - 7 of 7 Posts
Top