Road Glide banner
1 - 10 of 10 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
Has anyone experienced manual compression releases not popping off after the engine starts? If so, other than replacing them. How did you get them to work? I just installed a brand new set and they don't pop off when the engine starts. My last set worked fine until the plastic button fell off.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #4 ·
Tried WD40 all around them already didn't work. They stay open on their own so don't need to hold them down while it's running. I will pull them out and try spraing WD40 down into the plunger part of the releases. Maybe that will do the trick. Sucks that they don't work they are band new. Didn't work rite out of the box.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #7 ·
These are USA made all stainless steel units. Not cheap ones. A few bucks shy of $50 for the set. I received them Saturday and installed them same day. As soon as I seen they weren't working I sent an email to the manufacturer still waiting for a response. I haven't had a chance to pull them back out and spray them on the inside with WD40 yet. Will do tomorrow. Hopefully it'll do the trick.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #8 ·
I pulled the releases today and spayed them with a lot of WD40. No change at all. I never received a email response from the manufacturer, Vulcan Works. So I called them, the guy I talked to tried to say my bike didn't have enough compression to cause the releases to close. Bunch of BS. Then tried to say I damaged them installing them. No way. Then wanted to know if I bought them on E bay. Nope rite from Vulcan Works. I tried to give home my order number. He said to email it to him. And he would send me another set. He never responded to my last email. I think I'm out $50.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #10 ·
To my surprise I had a box from Vulcan Works in the mail box today. They sent me a set of replacement compression releases. Cool they kept their word and stood behind their product. I sprayed them down with WD40 inside and out before installing them. I gave them a try. No change, they didn't pop off. Bummer. I have a cheap set coming should be here by the weekend. They look just like the old ones I had before. Will see if they work any better.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top