Road Glide banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2021 HERE!
1 - 6 of 6 Posts

·
Registered
Joined
·
389 Posts
Discussion Starter · #1 ·
today out on the bike , a couple of times I went to start the bike and all the lights flashed but nothing. then pushed it again and started right up. could it a bad switch or maybe just the battery in the remote?
 

·
Registered
Joined
·
9,591 Posts
I would first check & clean battery connections and battery voltage. Then go from there.
 

·
Registered
Joined
·
253 Posts
I'd change the battery in the remote. All the lights flashed, that sounds like the security system.
 

·
Registered
Joined
·
9,049 Posts
Check whats already been mentioned but have a test light handy so when it happens again you can check for power at the starter. When it happens again ground the test light and probe the terminals at the starter while hitting the start button. If you have power at both terminals while hitting the button then you may have a bad starter. Also while hitting the button tap on the starter with the handle of a small hammer or screwdriver. If it starts while tapping then the starter is bad
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #5 ·
well I called the dealer and asked there opinion. he said the remote battery typically last 2-3 years. mine is 4. he said most likely its the remote battery going dead. so I will try that first before taking it back to them. I still have 5 months of warranty left.
 
1 - 6 of 6 Posts
Top