Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Ok, recently changed out handlebars, in the process I had to change out the clutch cable. When removing the clutch cable, I had to remove the cover with "Six Speed" on it. The fluid inside is crank case fluid correct? Or transmission fluid? :confused:

Second question, I test fired the bike this morning after working for 5 nights. Everything started fine, save for the fact that the bike jumped on me when I had the clutch lever pulled full back :eek: . Is the cable not tight enough or did I screw something else up?

Thanks in advance, electrical I get, mechanical not so much.

Chris
 

·
Registered
Joined
·
828 Posts
The fluid that came out is transmition or more likely gear oil. As for the lurch when starting, mine does the same if you try to start it cold without putting in Neutral.(which you should not try to make a habit of doing anyway)
 

·
Registered
Joined
·
83 Posts
If you have it adjusted correctly, then it sounds like the clutch plates are sticking together (common). I always work the clutch lever a few times before starting (cold start) to free them up. Yea, transmission fluid (gear oil) is what leaked out.
 

·
Registered
Joined
·
324 Posts
Use forumla plus or syn3 the trans or redline. Did you happen to not put the balls inside the cover a little off this sometimes happens
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
Thanks for the replies fella's. Gonna work on it in the morning and will check out all the possibilities.
 

·
GONE BUT NOT FORGOTTEN
Joined
·
3,813 Posts
OSUNO77, Just my 2 cents, purchase yourself a HD Manual from your HD dealership about $55. It will be the best investment if you plan on working on your own bike. BUT you can get GREAT INFO here also
Hillglide
 
1 - 6 of 6 Posts
Top