Road Glide banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've had my 2011 rg custom for about 2 months, and there are times that the cruise control doesn't want to set. The times that it does, when i have to slow down, or stop it doesn't always want to resume. It is always kinda hit and miss if cruise is gonna work or not. Has anyone else had this problem?
 

·
Registered
Joined
·
8,561 Posts
I've had my 2011 rg custom for about 2 months, and there are times that the cruise control doesn't want to set. The times that it does, when i have to slow down, or stop it doesn't always want to resume. It is always kinda hit and miss if cruise is gonna work or not. Has anyone else had this problem?
Make sure your brake switches are disengaging. (Not sticking on). 2010-2011 had a rear brake switch recall.
 

·
Registered
Joined
·
967 Posts
Brake and clutch disable cruise control when active, if slowing down by engine braking or braking cruise will be disable.
 

·
Registered
Joined
·
941 Posts
Make sure your brake lever goes all the way back out after using it as well as the clutch lever. I found mine wasn’t and it took me awhile to track it down. There seemed no rhyme or reason when it would or wouldn’t resume. I put in new bushings and the problem went away.


04 RG
 

·
Registered
Joined
·
2,195 Posts
There is a test sequence in the electrical repair manual, it's basically self diagnosing with some rider input to cycle the switches.

Beyond that, the thumb switches are susceptible to moisture, and the wire can break, inside the insulation, where they cross from the steering head back to the main harness.
 
1 - 5 of 5 Posts
Top