Road Glide banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,222 Posts
Discussion Starter #1
So I decided to upgrade my fuel and oil gauges to Dakota Digitals. Those are the only two gauges I wanted to replace. I kind of like the OEM tach and speedo. So wasn't planning on changing them.

On a side note..The install went fairly easy. Hardest part was getting the outer fairing on. Almost seems impossible to put back on without removing headlights.

Anyway, now for my problem. During my first ride I noticed my fuel reserve light was lit up on my OEM speedo gauge. But I knew I had 3/4 tank of gas. And the DD Gauge was reading 70%..accurate

I called Dakota Digital yesterday and they said their gauges will only work as a set. That my factory speedo reserve light will not be in use anymore. Which is fine for me. I could put a piece of tape over the light so it doesn't bother me. But my cruise control won't work now either. Kinda bummed because I really didn't want to spend the extra money for the tach/speedo.

And SWIII/ Sturgis trip starting in 4 days with no Cruise control stinks.

I guess I'll try and buy some gauges in Sturgis and hope everything works again,

Just needed to vent and hopefully let someone learn from me. Buy the whole set or none.

Ordered them from PC PAIN... He also was unaware of the problem of using just a few gauges. And not the whole set.
 

·
Registered
Joined
·
593 Posts
Now that's a crock of shirt. . . .no cruise and you have to but more . . . I'd return to the old gauges at least to get cruise for the trip?? Just saying :mad:
 

·
Registered
Joined
·
1,222 Posts
Discussion Starter #3
Great news!!!!

I guess I was setting my cruise control wrong the other day. By now, I guess you can tell I don't use it much :D It works with no issues at all. I rode the bike to work yesterday and tried it again.

The reserve fuel light on my OEM speedo problem is still there. But I can deal with that for now.

Sorry for the misinformation.
 
1 - 3 of 3 Posts
Top