Road Glide banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
I got a question for you all out there. I replaced all my gauges with Dakota Digital and they are great, except that my oil pressure keeps flashing. I have the warning set to 60, which is as high as it goes, but I have a high volume oil pump installed. I have read alot of things, and you can't turn off the warning. If there another sending unit that I can install that will stop the flashing. there are settings for 75 and 150 on the gauge itself, but only with the Dakota Gauge sending units, but I don't think that they are plug and play with my wiring. I have a 2013 RGU.

Thanks for any help.
 

·
Registered
Joined
·
7,346 Posts
What do the people at DD say?? I would think that the DD sending unit may be the only fix.
What does the oil psi read on the stock gauges??
There is no reason for the oil psi to be that high, 30 to 35 psi when riding is all that is needed.
I run my DD gauges with the stock oil psi sending unit and never had any issues.
 

·
Registered
Joined
·
2,790 Posts
Installing tomorrow DD gauges and if you're available Mark for any mind picking tips I would appreciate it.
 

·
Registered
Joined
·
5,892 Posts
I have the same thing for the first few miles until the oil warms up. I get up to 63 psi. To me it's not worth messing with another sending unit.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top