Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I just went through a troubleshooting session and maybe i can help others.

at around 10K miles, my RGS developed a serious rattling noise. I couldn't really figure out where it was coming from at first. It was more prevalent on deceleration right around 2K RPM. It really sounded like the bike was falling apart. Then when trying to locate it, i put my hand on top of the dash and it made it better, so i figured it was in there somewhere.

I pulled the windshield and lifted the top of the dash off and it was very apparent what the problem was. The top vent control system is only attached with double sided tape and one end had came loose and dropped down. So i got some 3M double sided tape, cleaned the plastic and re-attached the mechanism, patted myself on the back and put it back together. Took it for a ride and it was a lot better, but there still was a rattle.

So I pulled it apart again and tapped on it a few time and found another problem. there is a metal pin on each side that the vent pivots on. Well the pins are loose in the holes and allow the pins to vibrate. So I got a small flat blade screwdriver and got behind the "E" clip holding the pins in and slide the pins forward. Then I used some hot glue and ran it down behind the "E" clips around the shaft to hold the pin in place. doing it this way still allows the pin to rotate so the vent is still operational.

put it back together and took it for another ride.
SUCCESS........

At first I took this to the dealer and ask them to fix it and they told me this was normal and could not hear anything. I hate dealers.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
Yeah, i didn't think of pictures while i was working on it and now I'm afraid to take it apart that it will jinx it. LOL
 

·
Registered
Joined
·
134 Posts
Mine was making about the same sound..I finally figured out that it was coming from the tools and such that I had in the compartments, especially the lowers... I put rubber in the compartments and sound is gone...
 
1 - 6 of 6 Posts
Top