Road Glide banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 20 of 31 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
I got caught in one hell of a rain storm yesterday. This evening I was going to take a short ride and when I turned the key switch on everything was normal only for a second then the instruments and infotainment system went black. I turned the key switch off and tried it again. The headlight comes on and I can hear the fuel pump run up and that’s it. Nothing at the hand controls at all, no functions what so ever. I checked the fuses and the are all good. Could this have blown out a relay? There are two relays. One is the P&A and the other cooling. This is on a 2021 road glide special.
 

·
Registered
2018 Road Glide Special-Wicked Red
Joined
·
1,587 Posts
I'd say you still have water shorting out things. Try spraying the electrical fuse panels, any suspect areas where water could enter with electrical contact cleaner. Get a couple of cans. It won't hurt anything and evaporates.
 
  • Like
Reactions: Violeiro

·
Shark of the Month October 13
Joined
·
10,943 Posts
I would guess that there's an independent shop, closer than 100 miles from you, that could plug-in and check codes for you. Without codes, you could spend a lot of time and possibly a lot of money trying to sort things out.

Another possibility, would be to post what area of WI you're in and ask on here if anyone on here lives close enough to help you out by running the codes.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #12 ·
I’m 100 miles north of green bay and 100 miles south of Marquette Mi. Not much for indys in this area at all. I’ll roll it out into the sun and start checking connections for water. I have already checked the fuses. Is it possible the relay took a crap?
 

·
Premium Member
Joined
·
3,536 Posts
Have you done any work on the bike lately? Reason being, I as well as others I ride with have been caught in some pretty nasty storms with massive downpours and nobody has ever had any issues like this. If work has been done recently then maybe a seal on a connector didn't get reinstalled or coincidentally a connector didn't get plugged in all the way and is no longer making contact. Things to think about.
 

·
Registered
Joined
·
4,019 Posts
Have you done any work on the bike lately? Reason being, I as well as others I ride with have been caught in some pretty nasty storms with massive downpours and nobody has ever had any issues like this. If work has been done recently then maybe a seal on a connector didn't get reinstalled or coincidentally a connector didn't get plugged in all the way and is no longer making contact. Things to think about.
I’ve seen and read about this literally 100s of times.
 

·
Registered
2018 Road Glide Special-Wicked Red
Joined
·
1,587 Posts
I’ve seen and read about this literally 100s of times.
Exactly, as most connections have a rubber seal to keep our the elements, but if not locked/clicked in place a problem can surface later.
 
  • Like
Reactions: Violeiro

·
Registered
Joined
·
1,814 Posts
I’m 100 miles north of green bay and 100 miles south of Marquette Mi. Not much for indys in this area at all. I’ll roll it out into the sun and start checking connections for water. I have already checked the fuses. Is it possible the relay took a crap?
Possible, but not likely. I rode 8 hours in pouring rain last year and not a single hiccup in the sytem. Be sure to pull off seat and side covers when it’s sunbathing to get as much air flow throught the inner workings.
 
  • Like
Reactions: craigffb

·
Registered
Joined
·
89 Posts
Discussion Starter · #20 ·
Have you done any work on the bike lately? Reason being, I as well as others I ride with have been caught in some pretty nasty storms with massive downpours and nobody has ever had any issues like this. If work has been done recently then maybe a seal on a connector didn't get reinstalled or coincidentally a connector didn't get plugged in all the way and is no longer making contact. Things to think about.
Yes, this past winter I installed the Rockford fosgate stage 3 system. I just had the head unit flashed.
 
1 - 20 of 31 Posts
Top