Road Glide banner

1 - 20 of 52 Posts

·
Registered
Joined
·
1,428 Posts
Discussion Starter #1
Bike is 2010 road glide custom.

It has a Hogtunes 24.2 amp in the fairing that powers 2 Hogtunes 5x7 speakers.

I had a loose connection I fixed a month ago and all has been well. Suddenly on this past weekend, the speaker (I think left) is "static-y" at high volumes. It'll be fine for a little bit, then kinda sounds like its under water or something and is a bit choppy. Just not very good quality sound.

Is this most likely to be an amp, speaker, or connection issue? I have a spare hogtunes 24.2 amp. But if I need, or should get new speakers, I want to do that before I pull the fairing for the millionth time.

I realize my sound system is not "up to date" with what it could be.


What would you do in my position? I was generally happy with the Hogtunes setup when it worked properly.
 

·
Registered
Joined
·
6,588 Posts
Can't tell without listening to it but if you have a problem I would just contact Hogtunes, they have real good customer service at least they did when I was using their products.
 

·
Registered
Joined
·
1,428 Posts
Discussion Starter #5
Will you guys buy me a new sound system if I can successfully pull the fairing and reinstall it while completely blindfolded? Cause I'm pretty sure I'm about there now haha.



Are there better (louder) 5x7 speakers I should consider buying before removing the fairing since ill be there anyway? Or would different speakers not matter with the same amp?

I'd also consider larger speakers if they came with the adapter ring. I don't wanna try the zip tie thing again ha.
 

·
Registered
Joined
·
7,236 Posts
You can buy hawgwired adapter rings for 6.5" speakers for $40 online. I believe there's several more options for 6.5 than there are for the 5x7.
 

·
Registered
Joined
·
1,428 Posts
Discussion Starter #7
Would the 6.5" speakers with the new adapter rings be a big improvement over the hogtunes in it with the same amp? It's a hogtunes 24.2 amp.
 

·
Registered
Joined
·
8,758 Posts
Would the 6.5" speakers with the new adapter rings be a big improvement over the hogtunes in it with the same amp? It's a hogtunes 24.2 amp.
It depends what speakers you get. A better speaker will sound better , no doubt. The 6.5 infinity kappas I had sounded much better then the 5x7 hog tune speakers I had on the same pbr 300x2 amp. You will also need the stock 5.25 speaker mounts. That's what the 6.5 adapters mount to.

I have a set of 5x7 Hog tune speakers on the shelf. One is blown , go figure .:) . If you decide you need a speaker because one of yours is blown, let me know.
Btw.. When I blew the right side, all treble was lost on that speaker regardless of the volume. It was just more noticeable up loud.
 

·
Registered
Joined
·
1,428 Posts
Discussion Starter #9
Good to know. I don't think I have the stock adapters. I'll let you know what I decide. I'm u sure if its hurt or just loose again
 

·
Registered
Joined
·
8,758 Posts

·
Registered
Joined
·
1,428 Posts
Discussion Starter #11
Very helpful!

Where'd you get those and how much did they run ya?

We're they significantly louder than the hogtunes?
 

·
Registered
Joined
·
8,758 Posts
Very helpful!

Where'd you get those and how much did they run ya?

We're they significantly louder than the hogtunes?
I got them last year from Amazon for around a bill. The kappa 6.5's sounded way better/louder then the HT's 5x7. The Kappa 5x7's sound more fuller then the 6.5 kappa's, and also play louder.
 

·
Registered
Joined
·
6,588 Posts
Kyle it looks like you got enough cash left over after fixing the oil leak to buy some new speakers ;) See it wasn't that bad was it?
 

·
Registered
Joined
·
6,588 Posts
Glad to see you still have your sense of humor after all that!

Sometimes it is better to ride along and just hear the engine and the wind! :)
 

·
Registered
Joined
·
8,758 Posts
Glad to see you still have your sense of humor after all that!

Sometimes it is better to ride along and just hear the engine and the wind! :)
Sometimes, but sometimes not ! :)
 

·
Registered
Joined
·
1,428 Posts
Discussion Starter #17
I gotta crank some metal to relieve the frustration from the leak every now and again haha.



Now earlier (neighbors weren't home) so I started the bike and cranked the stereo to max volume. It sounds like both the upper speakers have static? It was on a CD, but sounded like an FM station that wasn't coming in clear. Could that be an issue with the amp and/or head unit?

I have a spare amp (same on that's in it.)

Maybe I best get speakers and change it all just to be sure to nail it in 1 shot.
 

·
Registered
Joined
·
1,428 Posts
Discussion Starter #18
Big_Gary:

Im really thinking on getting those Infinity Kappa 5x7's off ebay for $110 shipped. Did you need anything special for install? I already have the HT adapter rings for the 5x7's.

I think I'm gonna deal with a crappy stereo till I get speakers then swap the amp and speakers. I don't wanna fart with this crap again!



Next bike is gonna be all Hertz from the get go. I just cant justify (nor afford) that kinda stereo on a bike that has over 41k miles on her, cause lord knows im not gonna wanna take it all off later.
 

·
Registered
Joined
·
7,236 Posts
If you had to radio at full blast and the speakers sounded like crap make sure you have the gains adjusted properly. I know mine is a total different set up than yours but i can blast mine at full and they are crystal clear. Make sure the gains are adjusted
 

·
Registered
Joined
·
1,428 Posts
Discussion Starter #20 (Edited)
Are you referring to the gain on the amp? That's the only adjustment I know of. probably not the issue as this just started, but ill try anything. Might just pull fairing today and check connections I don't know. Got that funeral later so may wait.
 
1 - 20 of 52 Posts
Top