Road Glide banner

1 - 3 of 3 Posts

·
Registered
Joined
·
507 Posts
Discussion Starter #1
This kit allows the owner to connect switched and unswitched electrical accessories to a 2017 touring bike.

Well, I bought one, and the instructions are almost worthless. Plus, it says plainly on the instructions that it comes fully assembled, it is not. Whoever wrote these instructions was incompetent, to say the least.

The instructions do not explain what 325a is, 325b is or what in the hell the "secondary lock" is, or where it is. I tried to ask Harley with their online Q&A at the part site, no response. Sure did not help my mood.

Finally I Googled the connector and found the site below:

Help! How to install auxiliary electrical harness - Harley Davidson Forums

KY HDrider in this thread has it figured out, but he is the only one on that thread that appears to know what is going on.

Before doing anything else, disconnect the battery ground. Don't put the fuse in the B+ connector until everything else is hooked up.

The 325 is the black, three connection female plug, under the right side cover, that is wired into the bike with a weather cover over it. That plug must be taken apart to install the tiny female terminal on the B+ harness (fused 1/4" ring wire harness). This goes int the empty cavity on that plug. The other end goes to the (+) battery terminal. Take note of where the other two wires are located. The "secondary lock" lives in the female 325 connector. I never did figure out exactly what 325b is.

Follow KY HDrider's instructions, when complete, plug the kit in, put the fuse in the B+ connector and reconnect the ground. Test as below.

Wires coming from the update kit:

Violet /blue - switched (+)
Red/blue - fused constant 12v from the (+) battery terminal, the B+
Black - ground

Hopefully, this will save someone else the two hours of frustration that I experienced with this.
 

·
Registered
Joined
·
45 Posts
I just went through this the other night. Believe me when I say "I feel your pain"!

Sent from my SAMSUNG-SM-G870A using Tapatalk
 

·
Registered
Joined
·
43 Posts
So now I don't know what to do. The problem is that I installed the cool flow fan (26800128) which uses the 325A connector under the right side cover. It only uses the two existing wires, but that means I can't use the plug for the harness. So now, I have the coolflow fan plugged in and a hot wire just sitting in the harness unused and designated for something else.

Do I just pull the pin back out and connect it to the plug from the harness? I guess I could get a female molex 3 pin and route the fused wire straight to that.

Any help is GREATLY appreciated.
 
1 - 3 of 3 Posts
Top