Road Glide banner

1 - 12 of 12 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter #1 (Edited)
OK so last night I went for gas. Got down the street and radio went out and gas light came on(knew I was ready for gas), radio comes back on for a minute and goes back off and on again and fuel light goes out. Few miles later fuel light comes on and check engine light comes and goes. Got gas and was fine going home. Pulled codes when I got home and had the following, P0563,P1357, sb0563,spb1006,1007 and t b1006,1007 WOW. So it was late didn't check anything but will go over battery connections and check plug connections.Been looking on forum and am leaning towards voltage regulator. bike is 2012 rgu 95000 miles stage 1 no tuner. Any thoughts?
 

·
Registered
Joined
·
6,642 Posts
The VR is a good place to start, the 2012 has had a history of VR issues and there was even a recall issued by HD on the VR on the 2012 models. The p0563 code is a high voltage code and usually the 1st DTC is the problem and the DTC's that follow are secondary DTC's. Clear the DTC's and see if they return and if they do check the VR or just replace it. Replacing the VR is a easy DIY with basic hand tools. Don't forget to check the battery connections too.
 
  • Like
Reactions: Chunk

·
Registered
Joined
·
181 Posts
Discussion Starter #3
OK checked battery connections ,tight, took voltage reading at stator plug, 21vac at idle. Went for ride and about two blocks from home volt gauge pegs at 16. Returned home bought new voltage regulator and changed. Rode to work this morning and everything looked good. Need a longer ride but I feel good about it. Thanks Ironmark for your input.
 

·
Registered
Joined
·
8,856 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter #6
Ok checked and cleaned grounds. Put volt meter on battery and getting 12.46 volts idling, goes up to 12.5-12.6 if I rev it a bit,seems low. If weather permits I'll go for a test ride tomorrow.
 

·
Administrator
Joined
·
12,505 Posts
I'm willing to bet your stator is going bad, did you check it for shorts?
 

·
Registered
Joined
·
8,856 Posts
Ok checked and cleaned grounds. Put volt meter on battery and getting 12.46 volts idling, goes up to 12.5-12.6 if I rev it a bit,seems low. If weather permits I'll go for a test ride tomorrow.
A good battery should be reading 13> volts and not fluctuate much with acceleration.
I doubt you VR is going bad again but you never know. The VR usually are finicky when going bad, very rarely do they just stop working.
Battery mart sells the Big Crank battery for $109 delivered. Same battery as HD sells W/O the badge.
 

·
Registered
Joined
·
6,642 Posts
I did, didn't find anything unusual. When a stator goes bad does it go slow or just shit the bed all at once?
From my experiences when the stator goes bad the Voltmeter will read normal at when starting the bike cold and then as the bike warms up the voltage will drop below normal and it will keep dropping to a round 10 volts. Since the VR didn't fix the problem the Battery would be a good option to look into. If it's the battery Battery Mart is the place to go. It sound like the charging system is working as it should, the stator problems are pretty obvious but the
VR can be unpredictable,
 

·
Registered
Joined
·
181 Posts
Discussion Starter #11
Did a load test on the battery and it was good. Calling for rain most of weekend so wont get a lot of riding in. Be nice if something would just crap out so I could fix it and be happy.
 

·
Registered
Joined
·
181 Posts
Discussion Starter #12
OK after dragging my feet I finally purchased a stator and installed it last night. As expected old stator was burnt. Rode to work this morning and bike is charging as it should. Once again life is good, thanks for the input.
 
1 - 12 of 12 Posts
Top