Road Glide banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
OK. Got Cobra Fuel/Air management system, HD Heated Grips and LePera seat installed on new 2015 Road Glide. Had a problem reinstalling ignition Switch Knob, and a blown 20 amp, P & A fuse (pinched wire on left handlebar grip) that I had to work through. Bike is running awesome and heated grips work great. But, now when ignition is on or when riding, my Electronic System Alarm (ESA) on odometer is steadily flashing, and security system alarm is chirping concurrent with ESA light flashing. I've never experienced this before, but only have 800 miles on bike. I can't find the solution in HD Service or Owners Manual. And, I've read numerous posts on HD Forum and Road Glide website. When bike is parked and ignition is in off position or in Fork Lock position, the ESA flashes regularly, with or without Key FOB in proximity. Haven't had FOB near cell phone, and FOB battery is new. Had main fuse pulled when working on bike. Arrrrggggggghhhhhhhh!!!!! Any ideas?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
I didn't have time yesterday to work on bike, but I read somewhere that a low battery charge would cause the Security Alarm to activate, so I put trickle charger on battery and the steady flashing Electronic System Alarm and concurrent chirp when Ignition Switch Knob was selected for ignition went away - to be replaced by just a steady double chirp in ignition mode. Whatever happened to just working on bike and riding?????? There must be some "Road Glide expert" out there who can figure this out. I'm seriously considering disabling the Security System. Except, I ride Outside Alaska in summer, which is where a security system would come in handy. Advice???? Thanks in advance!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
The steady chirp was from the Boom box radio. If you work on electrical on 2015/2016 FLTR/FLTRXS, pull the 50 amp main fuse with the Ignition Switch Knob in Ignition "ON" mode. DO NOT pull 50 amp main fuse with ignition off. It f***s up your electronics. Simple fix - my radio needed reprogramming to stop chirping, plus dealer added software program update, all at no charge. I can't believe no one else has not made that mistake. Every other bike I've owned, you pull the main fuse with engine off. If you read fine print in service manual, it tells you that!
 
1 - 3 of 3 Posts
Top