Road Glide banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I purchased a 2009 roadglide earlier this year and have put approximately 2k miles on it. The bike has 17k miles now and I believe the person I bought it from had it in storage for approximately 1 year. The battery was going out so I replaced it, since then I have had these codes popping up and when I'm driving the radio comes on and off and the bike shuts off. Additionally the air filter cover gets extremely hot and continues to get hotter when the bike is shut off.
So far I have done the following:

1. checked the battery connections.
2. changed the voltage regulator.
3. changed the fuel filter.
4. put dielectric grease on the connectors under the seat. (I put the grease on last night and took it for a 20 minute ride, no issues ran great. But when I parked it in the garage the codes came back and the air filter cover began to get hot)

Codes tripping:
SP: b1006, b1007 T: b1006, b1007, P: p1511, P2101

Any suggestions is appreciated
 

·
Registered
Joined
·
988 Posts
I dont know about the air filter getting hot, but it's possible the ignition switch is bad or corroded, causing a bad connection and shutting down.

Lil Chief
 

·
Registered
Joined
·
483 Posts
B1006 - Accessory Line Overvoltage Instruments
B1007 - Ignition Line Overvoltage Instruments
P1511 - EFI Power Management Mode
P2101 - EFI Motor Circuit Range Performance (Actuation Error)

It sounds like the power going on and off cold be a bad power or ground. As far as the A/C getting hot, it is bolted to the heads so it acts like a heat sink so it will get hot just sitting there. There is no power going to it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks for the response, ya the air filter really trips me out. Especially that it heats up after the engine is off.
 
1 - 4 of 4 Posts
Top