Road Glide banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2022 HERE!
1 - 6 of 6 Posts

· Registered
Joined
·
144 Posts
Discussion Starter · #1 ·
My father surprised me with a Freedom Shields 14" dark smoke windshield for my 2015 RSG. It arrived today and I wasted no time putting it on and taking it for a ride (leaving the plastic on of course).
Man... What a difference it makes. Really cuts the wind, far less wind noise and I can hear the stereo way better.
When I got home I took a good look at things and I noticed a gap right in the middle above the vent. Went ahead and readjusted it, but it still has a fitment issues, to the point I can effortlessly slide two pieces of paper underneath the shield.

Has anyone else had this problem? Hoping it's a simple adjustment issue but could be the holes or shield is just plain off. Any advice or personal experiment is helpful.
(Yes, I plan on calling them tomorrow).
 

Attachments

· Registered
Joined
·
144 Posts
Discussion Starter · #2 ·
Posting mobile and having photo issues. Here is the gap and above is the paper underneath.
 

Attachments

· Registered
Joined
·
352 Posts
Picture doesn't really show much, but I appreciate that you have a problem.

Freedom Shields is very responsive, suggest you talk with him.

Did you "seat" the shield into the rubber ? Tighten from the center two, then towards the outside ?

There is "play" to move it around a little bit.
 

· Registered
Joined
·
144 Posts
Discussion Starter · #5 ·
Picture doesn't really show much, but I appreciate that you have a problem.

Freedom Shields is very responsive, suggest you talk with him.

Did you "seat" the shield into the rubber ? Tighten from the center two, then towards the outside ?

There is "play" to move it around a little bit.
Yeah, I seated in down and put the inside screws on first before the outside. It seems the holes are a tab off of the curve on the front is off by a hair (crazy as that sounds). Going to adjust it more after work with a fresh set of eyes.
 

· Registered
Joined
·
144 Posts
Discussion Starter · #6 ·
After speaking with John the past two days and trying his suggestions, he view the pictures I took and agreed there was a fluke issue. He is sending me a new shield to try along with a UPS return label to send my old one back.

By far some of the best customer service I have experienced and I highly recommend checking them out if you are shopping for a new windscreen.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top