Road Glide banner

1 - 13 of 13 Posts

·
Registered
Joined
·
6,539 Posts
Discussion Starter #1
I just put the PV in the bike not long ago and I set up the gauges for digital read out and most of the time they work but every once in awhile they will just stop reading out on all functions.
The only thing I can think of is that one of the plugs either at the diagnostic port or at the PV is losing connection.
I exit the gauges and then go back to the gauges and everything works as it should.
Anyone else have this problem?
 

·
Registered
Joined
·
44 Posts
My pv did that. Stop reset it an it was fine.
Come to find out my voltage regulator was going bad spiking voltage an shuting it down. Found out hard way after regulator went an took battery with it. After that its been fine.
 

·
Registered
Joined
·
3,042 Posts
Where do you have your cable routed?? If it's too close to a spark plug wire it can/will pick up
interference and lock up on occasion. better option is to pull the tank and run the cable inside
the wire tray under the tank.
 

·
Registered
Joined
·
1,186 Posts
I have that problem although I have to cycle my ignition off and on to clear it. The problem started when I installed the auto tune and routed the harnesses through the tray rather than beside it where I had the PV head harness. I spoke to Dynojet and they believe it to be an interference problem created by wire routing and asked my to reroute the harnesses out of the tray which I did today while adding daymakers and an amp since I had it all apart again. I'll let you know if that corrected it or not.
 

·
Registered
Joined
·
2,785 Posts
Give Dynojet a call. You can send it in and have it checked. If it has an issue they will repair it or mail you a new one. To my surprise they replaced one free that was out of warranty.
 

·
Registered
Joined
·
6,539 Posts
Discussion Starter #6
I have the cable routed down the tray, I don't believe that the VR is giving voltage spikes but you never know. I don't have to turn the ignition on/off the reset the PV just need to exit and re-enter the gauges.
 

·
Registered
Joined
·
2,785 Posts
Sending it to Dyno jet will ensure you are not chasing ghost. They do fail. My first Power vision would from time to time fail. Then it would be fine. I ignored it. Then one day it failed and did not come back. By that time I was out of warranty. Lucky for me Dynojet warrantied it anyway.
When it is working right there are no issue with them they work prefect all of the time.
 

·
EFI tuning and Exhaust Expert
Joined
·
815 Posts
I just put the PV in the bike not long ago and I set up the gauges for digital read out and most of the time they work but every once in awhile they will just stop reading out on all functions.
The only thing I can think of is that one of the plugs either at the diagnostic port or at the PV is losing connection.
I exit the gauges and then go back to the gauges and everything works as it should.
Anyone else have this problem?
If you are seeing the data drop on the PV there is a 99.5% chance that it is due to the PV cable being introduced to RF interference. In most cases this is caused by a spark plug wire or ignition coil. I would start by re-reouting the PV cable, if you have the cable ran under the tank and you are having an issue as tdkkart noted route the cable over the tank under the console and this should take care of it.
 

·
Registered
Joined
·
333 Posts
Give Dynojet a call. You can send it in and have it checked. If it has an issue they will repair it or mail you a new one. To my surprise they replaced one free that was out of warranty.
Nice folks to deal with.
 

·
EFI tuning and Exhaust Expert
Joined
·
815 Posts
Jamie, any chance of shielding the harnesses?
You may be able to shield the data cable however re-routing the cable will take care of it.
 

·
EFI tuning and Exhaust Expert
Joined
·
815 Posts
Also note there is one other characteristic to mention, if you ever get "buss error"on the odometer at startup this can cause the PV gauges to freeze. We have a PV firmware patch that fixes this, if your bike is doing this send an email to [email protected] and I will email it over.
 
1 - 13 of 13 Posts
Top