Road Glide banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
74 Posts
How do they ground?
Is it through the stem in which they mount on the clutch perch? so if so is the clutch perch move just enough to lose ground causing a short? Maybe try wiggling the perch with them on and not actually using the clutch to see if this is the case.

Might be as easy as taking off the perch and cleaning and reinstalling, or just a tighten up.
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #4 ·
How do they ground?
Is it through the stem in which they mount on the clutch perch? so if so is the clutch perch move just enough to lose ground causing a short? Maybe try wiggling the perch with them on and not actually using the clutch to see if this is the case.

Might be as easy as taking off the perch and cleaning and reinstalling, or just a tighten up.
I tried loosing the perch and waffling everything. The mirror light will go one and off while I wiggle the wires. I then tighten up everything again and when I apply the clutch the light goes back out as I squeeze on the clutch. As I release it the lights come back on. I just can't figure it out. Anyone have any other ideas what to look for? Like I said earlier, the lights work fine except when I apply the clutch. Then the left mirror (clutch side of course) goes out as I apply the clutch and then comes back on when I release it. Thanks....
 

·
Registered
Joined
·
250 Posts
Wiggling the wires implies that you have a bad contact and pulling the clutch handle is adding just enough pressure to cause it. Maybe bad connection in the mirror. Recheck ground and power.
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #6 · (Edited)
So today I took the fairing back off and found that the ground wire connected to the existing turn/running light on the front left just below the fairing was a bit loose in the connection. Funning thing is up at the mirror, if I wiggled the mirror the led's would go on and off as I wiggled it. But the actual problem was down in the fairing at the actual connection between the new wiring between that new mirror and existing turn signal. I simply had to tighten up the connection. Hope this helps someone else out. Thanks for all the help on this. It did help.
 

·
Registered
Joined
·
1,476 Posts
90% of issues with indicators are with bad earthing or blown bulbs. Good info thought.
 

·
Registered
Joined
·
74 Posts
Bear,

Glad to hear you found your problem! It's nice when you get an update like this. Enjoy your ride if your weather allows.

Bill
 
1 - 8 of 8 Posts
Top