Road Glide banner

1 - 7 of 7 Posts

·
Shark of the Month December 2013
Joined
·
679 Posts
Discussion Starter #1
Well i currently have three sets of 6.5" ZX series Hawg wired speakers. Two in stock location, two in the CVO lowers and two in the tour pack. I have one PBR 300x2 powering the front four and one PBR 300x2 powering the rear two. I cant turn my volume up very loud at all before the front speakers cut in and out. I spoke with Brian at Sidecarcycles today and he said that the RF amps arent 2 ohm stable. I read that they were but maybe the ZX series are pulling too much. I dunno.

So, tomorrow im calling him and ordering the RS400 Hawg wired amp and hooking it up to the front four speakers and gonna see how it goes. He said if it dont fix my problem and make me happy he will refund my money.

Has anyone on here had experience with the RS400?? Is it seriously worth the 400 dollars? Im gonna buy one regardless but wanna know what others have experienced.
 

·
Administrator
Joined
·
12,452 Posts
I have 3 CS 300s and 1 RS 400. Previously I had the RF PBRs, the RFs are nice, but the Hawgwired are better. You won't have heat issues, and unless you're doing something really wrong, definitely no cutting in and out at high volume. BTW check with Frank at Dragos, he can save you $$$$ on the price of the amp and he is an authorized dealer.

Sent from my SPH-L710
 

·
Shark of the Month December 2013
Joined
·
679 Posts
Discussion Starter #3
Thanks for the input. I wont ever buy anything from frank due to issues but im getting a pretty good price from another dealer and they have it in stock.

Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
809 Posts
Well i currently have three sets of 6.5" ZX series Hawg wired speakers. Two in stock location, two in the CVO lowers and two in the tour pack. I have one PBR 300x2 powering the front four and one PBR 300x2 powering the rear two. I cant turn my volume up very loud at all before the front speakers cut in and out. I spoke with Brian at Sidecarcycles today and he said that the RF amps arent 2 ohm stable. I read that they were but maybe the ZX series are pulling too much. I dunno.

So, tomorrow im calling him and ordering the RS400 Hawg wired amp and hooking it up to the front four speakers and gonna see how it goes. He said if it dont fix my problem and make me happy he will refund my money.

Has anyone on here had experience with the RS400?? Is it seriously worth the 400 dollars? Im gonna buy one regardless but wanna know what others have experienced.
Instead of calling a dealer for the advice call hawgwired themselves. I believe Justin is the name of one of the guys and he is a forum member.
 

·
Shark of the Month December 2013
Joined
·
679 Posts
Discussion Starter #7
Just an update. I got the RS400 watt amp and installed it today in the place of the RF300x2. This thing is simply AMAZING!!. The directions state that you will prolly have the gain in the 50-75% range after you fine tune it. This was incorrect. I only needed maybe 15-20% and it screams. I am truely happy i spent that money and wish i would have spent it at first until waiting.
 
1 - 7 of 7 Posts
Top