Road Glide banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,518 Posts
Discussion Starter #1
Had the H/W system installed this winter by the dealer while the bike was in the shop. The first time I washed the bike I blew the amp fuse. 2nd time I washed the bike the front 4 speakers wouldn't work for a couple of hrs. Something is getting wet and shorting out. Going to pull the faring off this afternoon and check all the connections. Any advise on what to look for? Thanks.
 

·
Administrator
Joined
·
12,452 Posts
How do you spray your bike? I only had that problem once. .... let daughter help and she started rinsing the bike like it was a car, lol, the inner fairing doesn't get that wet after riding all day in the rain. And I have a rain cover for those times. Do you have a cover for the face of your radio?

Sent from my SPH-L710
 

·
Registered
Joined
·
1,645 Posts
I have the same issue after washing and it is hit or miss. Have not blown a fuse but it does need to sit for a while to dry out.
 

·
Registered
Joined
·
1,518 Posts
Discussion Starter #6
Just got done pulling the fairing off and checking it. The only thing I saw was the speaker plugs were facing up. Think maybe water was getting in. I moved them back under the faring.

Sent from Motorcycle.com Free App
 

·
Administrator
Joined
·
2,681 Posts
If you think that is the problem... take something and fold it over the top like a rain shield on the top of the amp.

I thought about doing the same with mine... but Ive never had a problem and I thought I read that the HW amps were water resistant?
 

·
Registered
Joined
·
1,066 Posts
If you think that is the problem... take something and fold it over the top like a rain shield on the top of the amp.

I thought about doing the same with mine... but Ive never had a problem and I thought I read that the HW amps were water resistant?
I thought I had a issue with my amp so I called HW and we talked for a while. They told me that the amp would have to be under water to cause any problems. My issue was the head unit getting wet.
 

·
Registered
Joined
·
483 Posts
The problem is Your washing it, if you wife would do it like she is supposed to while your on the road then when you get home it would be dried out and all working properly ...LOL
 

·
Registered
Joined
·
3,265 Posts
Man that Sucks!, ya put out Money and have any kind of problems what so ever,...
If any thing else persists, I'd have to drop the hammer on the installer. Even if it is aftermarket parts that they dont sell!
Hawg Wired is a repultable Company for Audio in this Industry!
Gotta be them Genuine Harley-Davidson fitted parts that are the Culprit,...
Hope ya got it fixed Man.
 

·
Registered
Joined
·
1,518 Posts
Discussion Starter #11
Hey eagle how ya doin? That ain't gonna happen. Neano, I'm pretty sure the problem was the plugs. Every thing else was tucked back against the inner faring. That was the only place I could see where water could get in. Find out maybe next week.

Sent from Motorcycle.com Free App
 
1 - 11 of 11 Posts
Top