Road Glide banner

1 - 10 of 10 Posts

·
Registered
Joined
·
341 Posts
Discussion Starter #1
I have had a noise interface with my Hawg Wired Six pack system that developed just a few months after purchasing a year and a half ago. So I pulled the stereo and Amp fuse and went with out a radio for the next 6+ months. Last year in perpetration for my 10 day trip over Labor day I decided to look into the problem. When I first called them one of their techs sat on the phone with me going through troubleshooting it, which I greatly appreciated. I was told that it was not a problem with their Amp or Speakers and it was a problem with the head unit. So I went out and purchased a new head unit and tried to get it up and working before the trip. Problem still continued, so I called them back and they said that it most be the Biketronics controller. At this point I was leaving the next day on the bike to Colorado for my trip so I removed the controller and the new head unit, and returned the head unit to Bestbuy and the controller to Biketronics. Biketronics promptly sent me a new new one but I waited to install it tell after Christmas. Guess what that didn't fix it. Next I mocked up a different amp just to see and it no longer had a "white noise" in the speakers or a whine with engine. With this info HawgWired told me to send in the Amp and they will take a look at it but I would have to cover parts and labor because now the Amp is out of warranty and I can't find the receipt after we moved. I asked how long to expect for repairs and was told they would have it repaired and sent back within a week if it was something that could be fixed in house but if it went back to the manufacturer it would take a little longer. Rich also explianed that it would go to level 1 techs and if they could not fix it, it would move to level 2 tech and than onto engineering at the manufacturer if level 2 techs could not fix it.

I sent the Amp out and according to the traking number it was deliverd on New Years Eve. Of course I didn't expect them to start on it tell the next week. Looked on their website and noticed that it said that they had not received the Amp so I followed up on the 5th just to verify that they received it and was told they did and would start right away and level 1 techs would update the status by the next day. After no updates I called and spoke with Rich on the 7th he said he would check and call me back. Rich called back about in hour later saying level 1 techs just looked at it and was moving to level 2 techs. Still have no updates or return calls after calling on the 15th and today.

I am irritated that they are taking so long and seem to only check it out when I call. I blame myself for not being more proactive in fixing it while it was under warranty and do not expect them to cover it(lesson learned). I feel they should be a little more expedient on trouble shooting and repairs being we are at a point after 2+ weeks that they said should take less than a week.
 

·
Registered
Joined
·
483 Posts
I would see if they have record of your original call and complaint when the amp would have still been under warranty , they sent you on a wild hunt for a problem which took you until warranty had expired , if they had looked at it originally when you called it should have been covered, I would push them for a warranty repair since you did report the problem while still in your warranty period.
 

·
Registered
Joined
·
2,098 Posts
Definitely out of character for them. In my experience with them, I've had awesome customer service. A couple of months ago, they replaced one of my amps (almost two years old). Because of ......wait for it......a funny whining noise when I used RCA input. Good luck.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
498 Posts
Any time I've called them with questions, even about the parts I bought used, they've been nothing but helpful
 

·
Registered
Joined
·
1,645 Posts
My experience has been the exact opposite. Their customer service has been great and very helpful.
 

·
Registered
Joined
·
1,845 Posts
I've ran their products for years and always received great service , they've warrantied things out of warranty and talked me out of spending more money on upgrades they said weren't worth it.
 

·
Registered
Joined
·
2,702 Posts
I have had like two issues so far and both were taken care of at no cost to me. First one was under warranty an second one was four months after my warranty expired. Nothing but excellent service so far.
 

·
Registered
Joined
·
341 Posts
Discussion Starter #8
I would see if they have record of your original call and complaint when the amp would have still been under warranty , they sent you on a wild hunt for a problem which took you until warranty had expired , if they had looked at it originally when you called it should have been covered, I would push them for a warranty repair since you did report the problem while still in your warranty period.
They had no record of it. I should have been more proactive.
 

·
Registered
Joined
·
341 Posts
Discussion Starter #9
Definitely out of character for them. In my experience with them, I've had awesome customer service. A couple of months ago, they replaced one of my amps (almost two years old). Because of ......wait for it......a funny whining noise when I used RCA input. Good luck.


Sent from Motorcycle.com Free App
Funny you say that because they are telling me that they have never heard of this problem before. Thanks for the info!
 

·
Registered
Joined
·
987 Posts
I have to agree with whoever said this is out of character. I called them yesterday about a used amp i got on ebay. The figured out my problem right away and actually talked me out of spending more money with them when I explained what I wanted to get out of my system. I have had Hawg Wired in three bikes over the last five years and have called their techs three different times with stupid mistakes by me and they always helped me and did not make fun of my stupid mistakes. Nobody is perfect. My advice is give them another shot. They will probably get it right.
 
1 - 10 of 10 Posts
Top