Road Glide banner

1 - 5 of 5 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
symptoms was a clacking noise in the throttle body... didn't hear that noise before... didn't get 2 miles from the house.. when giving gas a loud BOOM (explosion type sound) Bike shuts off and will not start... Fuel seems to prime but no spark to start... If i'm not mistaking.. code was P1357... Bike is currently at HD now... They did the motor work... Bike was running fine for 2 months strong...

stage4 race kit
58mm bodies
259 cams
full exhuast
SE race tuner

What has been replaced....
spark plug and wires

swap for testing purposes
stock throttle body
Cam sensor
distributor
coil pack

Any thought would be great.... I'd like to be able to suggest something to HD as a starting point.... Got a feeling this is going to be expensive

thx
 

·
Registered
Joined
·
147 Posts
Ouch!

:eek: Our condolences, that SUCKS! :eek:

Noise from throttle body doesn't sound good at ALL!
Did they do an ECM check? Ecm failure comes to mind ???
 

·
Banned
Joined
·
60 Posts
I reverb or clacking noise is caused by a harmonic bouncing off the backside of the throttle plate in many cases. Unless you like to shift habitually at 5000 RPMs, that stage 4 kit sucks IMO. Especially on a Bagger and even worse yet on a Bagger that is loaded down and two up. As for the "Boom" it may have been the HD shareholders celebrating with gunfire and fireworks because if the profit margins they're seeing by selling the sub par components. That go Boom themselves if not reworked with better components. Sorry to hear about your misfortune but it they did the work and you used their components, their feet should be held to the fire I this one.
 

·
Registered
Joined
·
147 Posts
Stage 4

I reverb or clacking noise is caused by a harmonic bouncing off the backside of the throttle plate in many cases. Unless you like to shift habitually at 5000 RPMs, that stage 4 kit sucks IMO. Especially on a Bagger and even worse yet on a Bagger that is loaded down and two up. As for the "Boom" it may have been the HD shareholders celebrating with gunfire and fireworks because if the profit margins they're seeing by selling the sub par components. That go Boom themselves if not reworked with better components. Sorry to hear about your misfortune but it they did the work and you used their components, their feet should be held to the fire I this one.
The last 2 stage 4 259e equipped 103's I have seen on a dyno and ridden were pretty good actually. Turned 100ftlbs at 2600 rpm or so and ran up to 6500 wfo! Of course they had pipes that complimented the cam profile as well and a GREAT tune!

Not all stage 4's are far right powerbands, they can run great in the 2750-4750 range :D

It would appear this moco dealer has some issues... This should not be happening nor should it be a big deal to troubleshoot.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
The last 2 stage 4 259e equipped 103's I have seen on a dyno and ridden were pretty good actually. Turned 100ftlbs at 2600 rpm or so and ran up to 6500 wfo! Of course they had pipes that complimented the cam profile as well and a GREAT tune!

Not all stage 4's are far right powerbands, they can run great in the 2750-4750 range :D

It would appear this moco dealer has some issues... This should not be happening nor should it be a big deal to troubleshoot.
Last conversation was using a different ECM. Result was still no spark.

At Indy#1

Stage 4 race kit gave 121tq and 126hp. But that crap doesn't mean crap parked. Lol.

Thx for the replies. Will see what happens. Riding season looks to really be cut short this yr.
 
1 - 5 of 5 Posts
Top