Road Glide banner

1 - 2 of 2 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
BLUF (Bottom line up front): Looking for some specific electrical help related to ignition and gauges.
I changed to 16" changing bars (I internally wired them with extended wire kit), new extended clutch and brake cables.

I have no power to my ignition, bars, or gauge cluster (no lights). No radio, turn signals, etc.
I do have power to my alarm (chirps) and initial stage of fuel pump (I believe it is the fuel pump). Nothing beyond that...

I have checked my ignition and ensured all pins are aligned, although I did have it out a couple of times. I have torn the bike apart more than once checking every plug, ground, etc. I have checked every fuse as well. Right now the bags, tank, seat, outer fairing, and gauge cluster are all back off of the bike.

Questions:
Would a broken or disconnected wire inside my new bars cause a complete blackout of my gauges and ignition?
Is it possible to have one tumbler out of sync, causing the split between alarm etc?

I am a total loss on this one. Anyone have some ideas for me? I was supposed to be riding in Rolling Thunder today - no so much... Bikes been down for four days now.
Thanks in advance.
Ron
 

·
Registered
Joined
·
8,856 Posts
BLUF (Bottom line up front): Looking for some specific electrical help related to ignition and gauges.
I changed to 16" changing bars (I internally wired them with extended wire kit), new extended clutch and brake cables.

I have no power to my ignition, bars, or gauge cluster (no lights). No radio, turn signals, etc.
I do have power to my alarm (chirps) and initial stage of fuel pump (I believe it is the fuel pump). Nothing beyond that...

I have checked my ignition and ensured all pins are aligned, although I did have it out a couple of times. I have torn the bike apart more than once checking every plug, ground, etc. I have checked every fuse as well. Right now the bags, tank, seat, outer fairing, and gauge cluster are all back off of the bike.

Questions:
Would a broken or disconnected wire inside my new bars cause a complete blackout of my gauges and ignition?
Is it possible to have one tumbler out of sync, causing the split between alarm etc?

I am a total loss on this one. Anyone have some ideas for me? I was supposed to be riding in Rolling Thunder today - no so much... Bikes been down for four days now.
Thanks in advance.
Ron
If your ignition turns in all positions and locks , it should be good. I recheck for crossed wire when installing the extension. Also check to make sure your pins are making contact in the plugs.
 
1 - 2 of 2 Posts
Top