Road Glide banner

1 - 6 of 6 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
I just got my inner fairing back from paint and installed it yesterday. I had just purchased a HW 6 pack so I installed the amp and speakers. I can't get the outer fairing to go back on. The magnets are hitting the inside of the outer fairing so it wont't all snap back tgether tightly. I have checked the proper configuration of the adapter rings. What am I missing? I replaced the factory grills and I know its not that. Do I need to take the factory 5.25 plate out? I'm stumped.
 

·
Registered
Joined
·
3,265 Posts
Ya mite be lacking PATIENCE?
Glad I'm in O-Hi-O!,... (Round on the Ends and HI in the Middle) cause wouldnt want any bodily harm done here,..:)
I dont know,...check ur speaker adapters.
If they are wider on one end, ya mite have that reversed. Which would make sence, as to why the speakers are hitting!
Those things can be tricky.
But????
Post up sum pics, mite be able to see whats up?
It is a B---H tho. Be patient and remember to get those hooks latched in the fairing. Push up!,...then down to get those babys to latch.
Ur lil things on the sides need to be lined up too.
Take ur time!
 

·
Administrator
Joined
·
2,681 Posts
The adapters are supposed to be rotated a certain way... I think the fat portion goes in towards the headlights...

Just put them on last night backwards myself.... so I'm guessing that is what your problem is.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #5
I got it figured out. Had one of the adapters a 1/4 off. What would be wrong with labeling those with a top where the top needs to be? The 6pack rocks! Can't wait for the snow to melt so I can get out and hear it on the road. Thanks for the help guys. Here's a picture of the painted inner fairing.
 

Attachments

1 - 6 of 6 Posts
Top